VRML 2.0 import question?

I know this is probably old news, but I absolutely CANNOT import a VRML 2.0 into Blender. I’ve taken the steps of getting the older version of Blender (v2.25) and when I go to open the file, it says it’s not a blender file. The VRML header is as follows:

#VRML V2.0 utf8

IMAGINE VirtualGIS TrueColor Layer

ERDAS Inc, Copyright © 1998

So that all seems right… any thoughts? Should I be grabbing any Python Scripts?

Sorry, I am a Blender Noob, it probably shows… and I’m running on Mac OSX 10.4.8 on a G5 with 2gb RAM, if that helps.

The VRML 2.0 file is about 60 MB, could that be an issue? It’s a huge terrain model.

Any help is appreciated! Thanks.


I have only seen the normal script for importing VRML 1.0. The link below is to Accutrans, it converts between different 3D formats including VRML 1.o and 2.0. It’s not open source, or free, but it is reasonably priced - 20.00 usd.


Best of Luck!

OBI Ron,

Thanks for your reply. I’ve tried Accutrans (which is difficult as I am on a Mac) but it seems to crap out after loading about 80% of the model… I’ve also tried crossroads, and ModelPress 3D. Nothing seems to work. I’m wondering if the VRML file itself is too complex, or maybe corrupt, I’ll try to load it in a freeware viewer or something and check it out…

Although, I’m sure that Blender 2.25 DOES do VRML 2.0 because there’s a dialog box under Import Settings (Under File) that lists VRML 2.0 Import Options… I’ll keep you posted as to what happens. Perhaps we’ll just try to grab a different model.

I have already posted a message about how to transfer models from solid edge to blender.
VRML format seems to be the right answer, but the last version of se convert into VRML 2.0 (also known as VRML 97).

So my question here is :
Is there any script to import a VRML 2.0 file into blender???

Thanks a lot in advance,

Best place to look would be in the Python and Plugins forum.