VRML 2 import bug? BP225; BC223 (Mac OS X)


(secundar) #1

First of all, i’m a newbie. Please forgive me if I have missed the obvious.

The Knowledgebase did not help.

Using Wings3d 0.98.03, Blender Pub 2.25 (and beta 2.23), Cinema 4D XL7.3 all on Mac OS X 10.2.2. I have tried to get my textured model from Wings3d to Blender (both versions) and in all cases Blender reports that my wrl is not a blend file. A second attempt at opening (F1KEY) the same file will crash Blender.

I can import VRML 1 via Cinema 4D but that is not the ideal approach.

Any advice would be appreciated


(Manuel) #2

Mhh…I’ve the same problem…it can be really a bug…


(Rickta59) #3

Could provide a URL to the problem VRML2 file?

aka AerobicsBoy


(secundar) #4

Okay, have at it. There’s the files I was working on and then a simple cube. Both of which do not open for me.

http://garyritchie.com/VRMLtest/

This leads me to believe that Blender does not recognize Apple’s Python which is 2.2.1 which comes installed on Mac OS 10.2. Not only does the VRML 2 import not work but apparently any python script I try to execute fails as well. :frowning:


(Rickta59) #5

Your VRML is simple enough and valid. I was able to load it using the File/Open dialog
of blender publisher 2.25 on both linux and win32 without any problem. Sorry,
I don’t have a Mac to test with.


(secundar) #6

Ok. Thanks for trying. I think there are some platform specific issues with Python. I have set my Python path but when i run a script - any that call the os “import os” I get an error or it doesn’t seem to run. I’ve tried commenting out the import os line but it must be too important - it doesn’t work after that.

I really don’t want to spend the time to learn Python right now to try and solve this. There must be a mac/python/blender fella here somewhere.