VRML normals

GGGggreetings, i’m working with VRML 1.0 files, and it seems some normals are not going the right way, so instead of “viewing” the front side i see the back side, so it screws up the lighting when i display them with OpenGL.

those files were made with blender, is there a way to correct that problem?

Recalculate your normals before exporting. CTRL+N.


is it suppose to pop me a window asking for a confirmation?
cuz if it is, it doesn’t do it so i suppose it is now working :frowning:

Did you go into edit mode and select all the vertices first?

Also, turn off subsurf before you export, if you have it turned on.

You have to be in edit mode with all the objects verts selected. If you don’t get the confirmation nothing happened.


ok, i managed to edit one VRML files (i got a few mores to do… BUT, it seems even worse after i did what you said… i’m confused, i don’t understand why it doesn’t correct the problem… can it be related to the orientation the points were done? is there a way to invert some vertex orientation?
example: triangle has been defined with points 1,2,3, and they are clockwise, but i need them ther other way around like they would been declared 1,3,2.

is there a fast way to do that? and only on vertexes that were defined in bad orientation?

Perhaps then you have a non-manifold mesh ie 3 or more faces attached to one edge. If this is the case a program can’t decide which is the inside and outside of your object. In blender you can draw the normals of an object and see which way they are pointing and flip them if necessary. If worse comes to worse post your blend file so people can have a look at what the problem might be.


how do i draw the normals? maybe then i can flip the triangle so it will be easier

  1. press F9 to get to the editing buttons
  2. enter edit mode
  3. In the panel called “Mesh Tools 1” is a button called Draw Normals the NSize slider adjusts the size.
  4. Select all the verts of the face you want to flip the normal of.
  5. Then in the panel called “Mesh Tools” press the flip normals button.

Generally it is a better idea to fix a non-manifold mesh than to go about flipping normals.


the blend file is about 15 Mb of size, and i don’t think my boss would appreciate it if i post it.

i gotta display the VRML files in a c++ application using OpenGL. all the display is done. But like i said the normals aren’t good. In Blender if i remove the double sided option in edit mode, it appears the same way i manage to display it with my application. if someone knows the OpenGL function i gotta use to use the double sided directly in my application it would be awesome!

i think it would save a few people alot of time :slight_smile:

Just post a small section of the mesh where the problem exists – no need to send the whole model.


well, even tough i’d like to post some part of it, i can’t… my boss don’t want to. :frowning:

but i found out in blender that in edit mode when i disable the “double sided” option, the mesh shows the way i display them. So does anybody know how i cn do this manually?

is there a way to select a whole groups of triangles to flip their normals? because cheking a whole bunch of polygons is very long. i know there’s some pointing out of the mesh and some pointing in… so i’d like to choose every triangles that their normals point inside the polygon and flip their normal.

Bart may be able to help you – see this thread if you haven’t already:


Yes you can select multiple faces and then flip them. While in edit mode Ctrl-tab will give you a popup where you can set the select mode to faces. Hold down the shift key while selecting to add more faces to your selection.