VSE: How to build proxies at 50% size in 2.6?

There is Strip > Rebuild Proxy and Timecode Indices, but that always starts creating a 100% proxy, even when I set render size to 50% and have 50 selected in the strip’s Proxy/Timecode Settings.
I do not want a 100% proxy, I want a 50% proxy. How can I correct this annoying misbehavior?

Workflow:

  1. select strip
  2. if you prefer, set up a custom directory/file
  3. select proxy size
  4. in STRIP menu select REBUILD PROXY AND TIMECODE INDICES

Now, nothing seems to happen. However, check your proxy directory: the files were rendered correctly. So why is Blender’s VSE not using them? Why, we have to tell Blender explicitly:

  1. show the sequencer properties (n), locate VIEW SETTINGS way at the bottom. Choose your proxy. If you select a size without a rendered proxy, it will show up black!
1 Like

Yeah, but that only builds a 100% size proxy, I want a 50% one. Selecting proxy size does not change that.

Anyway, workaround: build proxies in 2.49, open Blender 2.6 and set custom directory to the proxy directory from 2.49.

@nemo: Herbert’s response covers all there is to say really.
If you only want to have a 50% size proxy then check only the 50% box in the strip properties panel. Do not check any of the other checkbox sizes. Make sure you remove any previously generated proxies though as that might interfere with the process.
Then set the proxy size in the image preview window to 50% and you’re good to go.
Should work out of the box.

That’s probably why it didn’t work earlier.

However, while I was retrying this, the resulting proxy video only has black frames and the preview also is all black. And yes, I DO have the correct proxy size selected in the preview window.

http://pic60.picturetrail.com/VOL1721/12059659/21443803/t-399651475.jpg

As this image shows, proxy size 25 is chosen, but proxy video file (as opened in QuickTime Player) shows black frame, video preview in Blender shows black frame, but Blender Render correctly shows DJ P0N-3 frame. Everything should’ve been showing this image, though I’d understand if proxy file itself is different (as proxy files in 2.49 were different too).

Did you try looking at the proxy file with an external viewer? I used to find some corruption of proxy playback if the timecode wasn’t set to FreeRun or similar.

I’m thinking that black frames usually means no data to display. It looks like you’ve set a custom proxy dir. Could it be that you’ve changed paths or file locations after generating the proxies? This would explain black frames.

You could also try starting with a clean slate, i.e. a brand new blender file, load all materials, generate proxies and see if/how it works. This is a must, especially if corruption is a suspected cause of the errors.

Btw, which version are you using?

I used Quicktime Player for checking the proxy file.

Blender 2.60 regular download from blender.org on Mac OS X 10.5.8. No directories or anything changed after creating proxies. I produced above result by starting up Blender, importing the video file. Setting the proxy directory and setting preview to 25%, Building the proxy. As soon as Blender was finished building the proxy, the preview showed black. I tried scrubbing to refresh, but proxy remained black. I rendered out a frame at 25%, that worked just fine. I then located the proxy file, opened it in Quicktime Player. This is the result.

I always use a custom proxy dir, I hate the cluttering it creates on my drive otherwise.

Set TC to “free run” but NOT “No TC”. Oh and you may have to the old proxy folders if that one has become corrupt.

I ran into another problem: When importing 2.5 blend files, the whole timecode setting does not appear. When attempting to rebuild the proxies, it will always create a ‘100’ folder, even though the images it creates in there appear to be of the correct size. But Blender 2.6 completely refuses to work with the proxies anyway. No way to rebuild, no way to use the timecode settings.

[edit] It’s also crashed Blender twice now. [/edit]

Tried again with different file. Movie file seems to build proxies right, places a “proxy_50.avi” in the directory where I want it. Proxy file is perfectly playable in external video player, looks fine. But when I have the preview in Blender set to “Proxy size 50%”, I get a black screen.
When trying to make a proxy from image sequences, it makes directories “images/100/” (while only proxy size 50 is selected, not 100), with only white images in it. According to my system, it even uses CMYK colour model. And with Blender preview set to “Proxy size 50%”, again, screen is all black.
Timecode settings only appear on the movie file, but even with that set to “Free run”, the issue is not solved.
I can only get a preview in Blender if I set it to “No proxy, full render” or “Scene render size”, but neither of these options uses the proxy and it will not play my sequence at full fps.

Unrelated to all this, I noticed Blender is using video files incorrectly, in a video I use in my sequence, it leaves a row of pixels at the bottom of the file all black. Possibly because the file dimensions are 800x500 and 500 can’t be divided by 8, but both Blender 2.49 and Blender 2.5 Have no problems with it. And the codec I’m using also can handle that, only Blender 2.6 won’t work with it.

If you can try it on other systems to verify fault, then file a bug in the tracker. To be honest I haven’t noticed these issues. Can you upload just a little clip of media for others to try out?

I’ve searched various places and found this very old thread which describes the best the problems i’ve got.
I’m running Blender 2.64.9 r52531 on a Windows XP SP3.
I always get a white dotted black frame in the preview window with settings other than “No proxy, full render” or “Scene render size”.
I’ve followed the steps described in post #2. Blender tells me “Building Proxies”. I’ve searched all harddisks. Nothing to find.
I’ve saved the blend file and reloaded it. Same result. No proxies.
I’d like to use proxies because the playhead gets reaaally slow when working with more than one strip or when adding an effect strip.
No problem when working with one strip (mov, 1280x720).

Michael

Seems to be an issue with the version i’m using. With 2.64.0 r51232 it works as expected. Proxy is built and usable.
The reason i’ve updated to 2.64.9 r52531 has been that the VSE to Comp tutorial wasn’t replicable because the preview only showed a grey screen (with or without Open GL and independent of the render type).
With the higher version the “grey screen problem” has gone, but now no proxies are built…

Michael

You could downloadMPEG-StreamClip and batch process videos into any size you need.

Usually i use SUPER by eRightSoft for converting videos of all kind. So that wouldn’t be a problem to convert all the movies before i put them into the VSE.
But inconvenient.
Furthermore there seems to be a change in handling with proxies (maybe a bug?). It works in 2.64.0 r51232 (official download on blender.org). It doesn’t work anymore in various versions i’ve downloaded from graphicall.org (r52342, r52531, r52546).
Until now i haven’t found a version where both the proxies and the “Edit strip with compositor” work as desired.

Michael

Get to the bug tracker, they are squashing them really fast these days!