VSE titles made in photoshop with alpha channel incorrect

So I make some titles with arrows in photoshop, and generate an alpha channel using “Image->Calculations” method.
I load the title (either tga or tif) into the VSE, set the strip blend mode to Alpha Over, and enable Premul. It works, for the most part. except my black drop shadows are white, instead of black/gray. Why? What do I need to do different?

Thanks in advance.

That may be the background you have it multiplied against or the tiff/targa formats but without the file or at least a screen shot it’s impossible to say for sure.

attached:
top: as it appears in photoshop (with white strip to show the shadow).
Mid: as it renders out of Blender VSE (and appears in the preview)
Bottom: Alpha Channel

see how the drop shadow is white instead of shades of black?

When the image loads in the VSE, with default “replace” blend mode and no premul, it’s as if it has a white background.

ideas? Is there a way to change the default background color in photoshop, if that’s what’s causing it?

edit:
ummm… what’s with the jacked up PNG?
see link:http://loklomedia.com/blender/example-alpha-prob.png
or:http://loklomedia.com/blender/example-alpha-prob.jpg for how it looks in photoshop

Attachments


Try creating a flat black BG for the arrows & type – no drop shadow – but use the same alpha channel as you now have. I think the white/gray from the drop shadows’ edge blend is creating the problem. The alpha channel shown should define the drop shadow shape well enough but with no “white pollution.”

well that’s a nice work around, but is this a bug in Blender? Or am I prepping the image wrong in photoshop?

It’s not a bug in Blender. What you’re doing is creating a drop shadow that is in effect a grayscale gradient, which means that the lighter shades contain a substantial amount of white. The alpha channel creates a soft-edge mask for this, but you’re still blending grays, not soft-edged black. For example, at one point in the soft edge, you are blending a grey tint of 30% black + 100% white (rather light). The alpha channel doesn’t change this, it just lessens the effect somewhat by making that area somewhat transparent.

The only way to make such drop shadows work would be to use either a Mix/Multiply or Mix/Darken node, but that wouldn’t help your white type any. By using solid black, the alpha channel alone will determine the amount of black added to the underlying image, which is what you’re trying to achieve.

ok, I understand what you’re saying now.
Surely that’s not a standard implementation though. When I use this as an overlay in Sony Vegas, it looks as expected.

Yes, I’d say this is “standard” implementation, given the way you’ve set it up. In this case, I think if you set up a similar arrangement in Photoshop, using layers and a layer mask (your alpha channel image), you’d get similar results, if you use a normal blending mode.

Keep in mind that “overlay” is not the same as “alpha over” – two different blending modes – plus you can never rely on an exact match between apps in how such things are accomplished. For example, Photoshop layering with a layer mask is very similar to Blender’s alpha over, and in most cases looks the same, but can sometimes look noticeably different, depending on settings, nature of the matte/mask, and other aspects.

Better to find what works to accomplish a certain end in whatever app you’re in at the time, with correlation between apps as a guide.

alright. Thanks for the help!! (too bad there isn’t a gimp based title plugin/py script for the VSE).

The problem likely is that PS natively works in premultiplied alphas. Use an alpha convert node and set the type “Premul to Key”, then after render premultiply the image over your strip in VSE. See the image solution in this post but use a Set Alpha node in place of the Alpha Over node:

http://blenderartists.org/forum/showthread.php?t=161980