wacko normal map behavior

Can’t upload my blend file, but this picture might do the job.
Normals show up in the preview window, but I either get nothing or sharp blacks spots.
Tried it in the latest build as well as the release, same result. As usual, nothing I adjust makes a difference.
(I cut this WAY down from a large landscape project to a simple example)
Is it a bug or am I overlooking something? (dang, wish I could upload the file!)
thanks


![file:///D:/Cult%20Game%20Project/2-Storyboard/GC2/Clipboard01.jpg](file:///D:/Cult%20Game%20Project/2-Storyboard/GC2/Clipboard01.jpg)

The normal map needs to be changed to ‘tangent’, make sure the mesh is UVmapped for it to work.

Hmmm, that worked, the uv mapping part. Why would it work fine in the GLSL view and not the render? A shortcoming in the normal map calcs in the renderer?

My normal map is in world coords though, why would I use Tangent?
In this case, I have a large-displacement terrain as a lower-level mesh, and a higher-rez normal map to perturb the surface with about 8x detail. GeoControl is the source of both, so the fit is one-to-one and projected orthographically from an overhead view. Shouldn’t that be simple enough to use Generated mapping coords? (it is if I feed the normal map image to the color channel !)

thanks for the tip!