Wacom Intuos 4 driver : no pressure in Blender and Gimp !


Very bad news for me today : I have a small A6 Wacom graphire 2 tablet, working perfectly in Gimp and all my other softwares. It is good enough for photo correction, but not handy at all for drawing, because of the limited movements due to its small size. So I was saving money for a long time to buy a professionnal graphic tablet.

I finally purchased an Intuos 4 XL (830 Euros ) and got it yesterday… I have installed it yesterday evening and I have set the shortcuts for the customizable buttons, a very useful feature. I have tested it with my old Photoshop 5.0 LE, Photoshop Elements 2001, Dogwaffle Pro (painting software), Blender and Gimp… It works in Photoshop 5.0 LE and Photoshop Elements 2001, except the eraser. It works in Dogwaffle Pro with the eraser (the eraser gives the background color in Dogwaffle, but it is normal), but it is not sensitive to pressure in Blender and Gimp ! I must precise that Pressure sensitivity is enabled in both softwares !

My old Graphire 2 works perfectly in Gimp and after installing the most recent Wacom drivers for Intuos 4, it is even sensitive to pressure in Blender… but the Intuos 4 is not !

I use Blender and Gimp every day and I had purchased this tablet to create textures in Gimp and do rotoscoping and matte painting in Blender. It is a nightmare ! :frowning:

My Adobe softwares are old light editions not allowing some image formats. Gimp perfectly matches my need and I can’t afford purchasing Photoshop CS4.

If someone is owner of an Intuos 4, please test it in Blender (for drawing in the image editor) and Gimp and tell me if it is sensitive to pressure.

If you have an idea to make it work, I’ll really appreciate ?

I’m working under Windows XP Pro Sp2 32 bit.

I will contact the Wacom support as soon as possible, but I am not sure that they will take it serously if I tell them that I work with free softwares… I fear that they will say that it is the fault of the softwares… even if their previous tablet worked fine on these free softwares…

Thanks in advance.



I have an Intuos 4 M (yeah small one compare to yours :p) and don’t have any pressure problem in both.

I run it on Windows XP x64.

I guess you did the settings on each software. Maybe you should try to uninstall all Wacom drivers (Graphire and Intuos) and then only install the Intuos one.

I’ve tried a Intuos 4 in blender (OS X) and the pressure sensitivity works in the image editor.

@kagi and Richard Marklew : A big thank you !

My Intuos 4 tablet works fine in all my softwares, and even the eraser works !

The Wacom software displays all tablets you connect on the computer, but seems to accept drivers for only one tablet family (Graphire,Intuos…), so I have plugged my Graphire on my old PC and I will use only the Intuos on my best machine.

I had the hope of being able to use the Graphire from time to time for simple works when the big one isn’t required (when doing mainly 3D work), because it is easy to keep it on or near the table, but the most important is that the big one works fine for my 2D drawing !

Now I’m going to program again all my buttons shortcuts : an other busy day !o))

Thank you again for your posts ! I will sleep better tonight !

Edit : Well, there is still a problem, but it seems to come from a bug in Blender :

I’m working on a rotoscoping, and I have noticed something very annoying : Each time I hit F12 key to render my frame, the tablet pressure sensitivity is lost ! The only thing to do is to close and re-open Blender to get it work ! This means that it is not possible to control your rendered mask during the drawing without loosing the pressure sensitivity.

I worked with Blender 2.48a. I have just downloaded and tested with Blender 2.49 RC3 Windows Zip (both versions with Python 2.5 and 2.6), and the bug is here. I hope that it will not be in 2.49, but maybe it is too late to correct it…

I have confirmed the problem with my Wacom Graphire 2, and my Intuos 4 XL on two different machines running Windows XP Home edition SP2 and Windows XP pro SP2…

I have reported the problem to the bugtracker, but it doesn’t appear in the list… Maybe it needs sometime to be validated. I hope that it has not been dleted…