Wacom pressure sensitivity doesn't work well at all in 2.5

I’ve been spending some time sculpting and I’ve noticed some glaring issues with pressure sensitivity. In windows, it simply doesn’t work at all, and on mac, it works, but causes a lot of slowdown and hitching with strokes.

I looked around and saw that the old 2010 “merwin” branch made a lot of fixes for tablet support, but does it fix the above issues? If so, what’s the current plan for when those fixes will be implemented?

Oh, and if I’m just missing some setting that makes wacoms work, please let me know, because no pressure sensitivity is a HUGE problem for sculpting and texturing :slight_smile:

Thanks everyone!

I have the same problem. No pressure sensitivity in texture-paint nor sculpt modes using Wacom Bamboo from Blender 2.57 right up to the current 2.59 RC on Windows 7 64bit. I had not tried using my tablet with Blender on Windows before the 2.57 release. My tablet is working correctly for other applications on Windows.

Wacom pressure IS working, however, in my Arch Linux environment where I build Blender from source every couple of days.

I’ve noticed quite a few discrepancies between platforms in that somethings just plain don’t work in Windows. It’s exasperating.

I found the pressure does not works only in texture paint mode, I get pressure on sculpt mode tho, dunno why its not working on paint mode,
maybe we need to file a bug, bw I’m using an intuos4 on windows7 and blender 2.59

Windows 7 64bit Blender 2.59 r39307 (official release):
No pressure sensitivity in scuplt mode, nor texture paint mode. I do have pressure sensitivity when I enable ‘image painting’ in the UV/Image Editor. That would be pressure sensitivity in the image editor only… Doesn’t work in the 3D viewport.

As I made mention prior, it does work for me under Linux (Arch 64bit) but as I am building assets for use in a Windows based game engine/editor (Unity3D), I really need a solution that works with my Windows install.

This is a show stopper for me. I need texture painting in the 3D viewport to work.
Sad to say I’ll have to give up on Blender and look at other solutions.

Hmm… does no one have any definitive answers on the state of wacom support in Windows 7? Lots of people are having problems, it would be great to hear what’s being done (or NOT being done) about it, just so I can stop guessing and assuming things.


I’m on win7 32 and have no pressure with my bamboo on Blender, but I do have it on photoshop and sculptris.

Windows 7 64bit Blender 2.60 RC1 : Bamboo Wacom works !!! I’m positively chuffed.

Can anyone confirm that Blender sculpting feature isfully functional with wacom? I have troubles getting blender working with Wacom Intuos3 and Graphire4 in Linux. The pressure sesitivity is lost sporadically. In gimp and mypaint tablets work great.

I figured I’d bump this thread up.

I’m using windows 7 64-bit. I have a wacom bamboo pen. In both the 2.62 release and a five-hour-old build from graphicall.org the tablet’s pressure information just isn’t being picked up in sculpt or texture paint mode.

Edit: It’s not working at ALL for me in the 5-hour old version.

Just to confirm, it works just great for me in ubuntu. Unity needs to release a linux version of their editor. ><

Works great for me as well. No problems: Wacom Intuos 1, win64-44774 Bat3a build. See my sig for other info.

Works great for me (Linux 64 and 32bits). May you had same troubles described in (see the picture. I tried to describe how I solved my problem in linux). Also see last message