Walk cycle and path following

Hi everyone! I’m having a lot of trouble trying to get my character (with rig) to follow a path. I am not sure how to do it. I have a walk cycle created in action editor and I would like my model to walk around and not just in place. I created a path and parented to the object, it didnt work, it basically screwed up the object (model). So I parented to the armature, which didn’t help either because the armature follows the path but the object (model) stays back and is warped because the armature is moving away. I just can’t seem to get my character to follow the path and walk. I tried parenting my armature to the object and then parenting to the path but the object just slides across the path in the position it is in.

Any help would be very useful. It took days to make my character and days to get the walk cycle. Now I would like it to do more than walk in place.

You could give the model the constraints: Copy Scale, Copy Rotation, Copy Location with the target Object “Armature”. That should keep the model in place.

Attachments


If Optimus’ suggestion doesn’t do the trick, there is something I think might help.

These path following threads are popping up like wildfire (I’m guessing there is a tutorial that people are referring to?). First try creating an object like an empty and constraining it to the path, making it follow the path however you would with your character… get that working first. Then you can constrain you character to that object once it is setup… which should leave your character in the same starting place if you use local space on a copy location constraint for example.

It may be better still if you use a bone within your armature, and get that to follow a path or an object constrained to the path…

The key I think is to get a null object/bone in place first, and then get your character to follow that null object/bone in local space. If you follow me…?

It sounds like you might have unapplied alignment/rotation issues, because parenting the armature to the mesh then using the follow path constraint (to the armature in Object Mode) should work … Unparent/unconstrain everything and use the Ctrl-A (apply scale and rotation) to all objects then reparent/reconstrain in the order I described above and see if that works … you might also have to change the path’s orientation from positive Y to negative Y (in the Buttons window in the F7 Object context in the Anim settings panel) …

These path following threads are popping up like wildfire (I’m guessing there is a tutorial that people are referring to?)
Well no … there is some confusion with getting a rig to follow a path because there are several ways to do this … There is the above method, which works for simple setups, then the more sophisticated method that you describe feelgoodcomics, that of making the root bone in the armature follow the path (I don’t think you need the empty for this), then the stride bone option in the NLA (which is a variation on the root bone option except the stide bone is animated), and then lastly the offset forward cycling walkcycle/curve deform method (also accessed via NLA), which can resolve the “foot slipping” issue that can come up with the stride bone method …

Any of the above methods will work as long as the armature and mesh are properly set up . But mostly the path following questions are about the last method which can be confusing to set up if you do not understand the armature hierarchy in your rig … The “offset” part in offset forward cycling is not possible in certain setups for example …

I think I got it figured out. It took a very long time now I just have a lot of foot slipping. I want to fix this and I have tried http://www.telusplanet.net/public/kugyelka/blender/tutorials/stride/stride.html I got to the point where it shows you how to add it and what to do but I can’t seem to follow very well. Could you maybe help me with the stride bone. I can’t seem to get it to work

I have done my walkcycleswith old python script.

kkrawal that was awesome :smiley:

duoc9119,

The first thing I saw when loading that tutorial was that it is outdated as of version 2.43… could that be a problem? I personally have no experience getting a character to follow a path, my suggestion was pure speculation - based on experience from a separate but similar problem.

lol i give up on the stride bone. It makes no sense. lol I got the path following to work though. I parented the model and the armature and then parented to the path. After that all I had to do was adjust the IPO editor for the path. I would upload a clip of the walk cycle but I can’t figure that out either. lol