Walk through floor glitches

i am making an animation of a person walking…is there a way to make it so when i drag the mesh, it won’t pass through the plane(in this case, the plane is the floor). This way there won’t be any space left between the feet, or they won’t sink through the floor.

2.4 will have Floor Constraint. In 2.37 you need to goto the IPO window and Tab the selected curve(s) into edit mode, select the key where it hits the floor and press V to turn it to a Vector Handle so you can make a straight line of the curve. Do it again where it leaves the floor. 2.4 will also have new interpolation options and new curve types that’ll make this tweaking unnecessary.

%<