Walkcycles on a path

I’m attempting to do a simple walkcycle and have it follow a path. I’m doing this just like it says in the 2.33 guide: put the walkcycle as an NLA strip on the armature, then normal parent the armature to the path and set ‘use path’ and the stride parameter to match.

This has only worked one time.

I can duplicate the armature and path that it worked on, but that’s cumbersome and cannot be imported (to my knowledge) to another file completely intact. With that one successful exception, every time it has stretched/compressed the walkcycle to take up the path in one stride. This looks horrible, as it slides all over the ground. For the moment I can workaround, but soon I’ll have to make more complex paths and I just can’t do that in the present situation. Can anyone tell me what I’m doing wrong? I followed all the steps in the book, and it just isn’t working.


When parenting to the path, use the Parent option, not the Follow Path option.


As noted above, I already did so (just like it says to do in the book). It still acts just as if it were on ‘follow path’. I can’t understand why it’s acting this way.

While I’m at it, let me go ahead and cover some of the most likely questions (lest you think that I’m just not following what the book says to do):

Did you turn it into an NLA strip?


Did you put the strip on the armature?


What kind of parent did you use?

‘Normal Parent’ option.

Did you set the stride parameter?


Did you push the ‘use path’ button?


Did you adjust the speed curve?

No. I haven’t started with it yet because I can’t get the walkcycle to synch with the actual distance covered yet.

Does that help?

Okay, I FINALLY found the problem.

I accidentally discovered it when I mis-set the stride parameter to something insanely large just a minute ago while fooling with it.

The stride parameter seems to be auto-doubled. Apparently that’s a change from the previous version, because there’s no mention of it in the book. My guess is that it’s designed so that you only have to count one step of a bipedal stride instead of multiplying it by two. It was partly my doing, because I miscalculated the stride length, but the program was also doubling THAT, which messed it up royally. The cycle covers a distance of 4.0 units (when correctly calculated), so that’s the figure I put in the stride parameter. But in fact, after experimentation I found that only 2.0 units will make it sync correctly.

(And before you think that I’ve got it set to display double increments or something, I did this cycle by the numbers, not visually.)

AFAIK, the stride parameter was always the length of one step, where each cycle in the animation is two steps.

Could be wrong of course, but I’m pretty sure.


Well, if that’s so, then the tutorial in the book is really messed up.

“The Official Blender 2.3 Guide” says that you have to multiply it by two. (I might have caught that sooner if I hadn’t also mis-calculated the distance covered in one full walk-cycle.)