walking with cape cloth modifier

Can somebody help me out when my character is walking his cape keeps blow up as if he is flying.
How can I let it hang down and act more natural.
Can see the result only when using topmenu - Render- OpenGL Render Animation

http://www.antoons.org/blender/Jester-walkingtest.blend

3 days late. Meh. If you’re still having this problem you could possibly try increasing the mass of the cape (in the physics tab). Failing that you could try increasing the stiffness… however I’m sceptical about how natural it would look by doing the latter.

yes still having problems the problem is when the character is going to walk.
Increasing mass or stiffness did not work. Increasing velocity did work but halfway the walk when he is making a corner the cape is blow up again. Maybe I have to make a shape key for the cape. Cloth addon is not working fine with animation.

I’m unable to download the file, but you might also try decreasing the Air influence. I’ve found that often has the strongest effect on unwanted puffing of cloth. Make that value very low and then the character’s movements will be the primary influence on the cloth’s movement.

You can also use helper bones in the cloth itself. For dangling cloth this is usually the best way to control where it goes, but it can be tricky. I’m actually working on a tutorial that uses this method right now. I’ll let you know when it’s done.

Download should be working now had some ISP problems.
Air is set to 0 . should I use cloth field weights?

This is the original blend file made.
http://www.antoons.org/blender/Jester-Group.blend

Field weights can give you more control, yeah. For instance you could make it so the wind only really affects the bottom corners of the cape to give it a little flutter. As a sort of analogy, in the movie Pacific Rim, the waves are not physically accurate at all: the robots and monsters are all about 70% permeable to water, so only about 20-30% of any given wave (it varied by shot) actually crashes into their surface. The rest passes through as if they were ghosts. It’s not physically accurate, but it looks right. The physically accurate behavior for water and creatures of that size and mass was essentially a tsunami every time they took a step. By the same token, you want most of the air to pass right through the cloth, rather than push on it.

Other things to consider:

  • The Air influence and the influence of a wind force field are, I believe, considered two different things.
  • Dirty little secret: You can edit a baked cloth simulation in Particle Edit mode. If one bit absolutely refuses to behave the way you want, you can fix it manually with the same tools you use for combing hair.
  • If you’re using Pinning, the vertex group for pinning can have partial weights, so you can have vertices that are only partially participating in the cloth simulation.
  • There are some very good example files on the documentation page. http://wiki.blender.org/index.php/Doc:2.6/Manual/Physics/Cloth

Thanks just wondering why all flied weights options are set to 1 by default.
Unfortunately most examples are no moving object by them self.
When my character is standing still the cape waves pretty good but he needs to walk
without wind-force 8.
Anyhow I am still struggling with my character cape trying to make it work better with the help of shape keys.

Field weights don’t really matter at all unless there is a force field of that type at play. Except gravity I think, because your scene has gravity.
Shape keys can help, but try some helper bones in the armature. That might give you broader control.

Oke now I understand.
I am disappointed when I should use helper bones.

yes I made a new cape test first set the shape key to the position I want.
Then I added another cloth an increased the mass this looks pretty good .

http://www.antoons.org/blender/capetest.blend

Oh, increasing the mass never occurred to me. You should probably be careful with that if your character moves fast though, because that could end up giving it too much forward momentum, but that’s definitely a good way to hold it down. I wonder if perhaps it would be better to increase the influence of gravity instead. I’ll have to play around and see.

Yes but increasing the mass without setting a shapekey first didn’t work I tried that before.

Thanks problem solved

Excellent. Can you share the final version so we can see exactly how you made it work?

Yes no problem thanks for all the info and tips.
Will post the final here as soon as possible.

Not my best animation but its a start.

[video]www.antoons.org/blender/walking-test.mov[/video]