Warblender and script


(guitarplay) #1

hey, ive been using blender, in small ammounts, and ive just completed a big project (for me) It is a gundam model, and it has taken me a lot of time. Problem is its not for me, its for someone else, and i cant conver it with warblend. It installed, and comes up correctly, but when i try to export as a mdx, it say, there has a been a “scropt error”, please check something or other

what do i do here, and i have a feeling, its related to the message in command prompt whenver i open the program that says, ‘no python scripts found’

if anyone could halp me that would be great, but i dont exactly know it this is the right place to post this


(jaycun) #2

Do you have python installed? Please post the contents of the commandline window. . .


(guitarplay) #3

mk, heres the deal. I unzipped the python stuff, but its all PY files. If i knew whre to put um that would be grat, but i havent figured that out yet

when open the program, here what i get

Using Python version 2.3
‘mport site’ failed ; use -v for traceback
No installed Python found
Only built-in modules are availible. Some scripts may not run.
Continuing hapily.

???, thats not good, but everything seems to run ok

now i open thing, and try to export a warblender Blizzard file (.mdx) and i get this

ERROR: Python sript error: check consol

thing is this gives me a weird error on the cmd prompt like this

Traceback (most recent call last):
“(string)”, line 10, in ?
Import Error: No module named warblender.mdx


(Alex_G) #4

You need to install python

Download it, then go here:

http://www.elysiun.com/forum/viewtopic.php?t=7723


(guitarplay) #5

ok. . . i installed python, but i cant hook it up with blender. IM confused

Blender comes with a file called python, cant i just put those py files into the scripts folder, or a folder in the .blender folder, something like that. All i want to do is use warblender, i realy dont care much bout python, unless i need to use it. . .

Some plz help me


(jaycun) #6

You need to set your python path so blender will see it.

read this
http://www.elysiun.com/forum/viewtopic.php?t=7723


(guitarplay) #7

well, the third post is what i need, but the problem is i cant find the info window in my blender program!!!. thats my only problem.

I installed python correctly, and i set the variable in my computor for the directory, but i cant find the info button in blender, and thats where i gotta stop


(Alex_G) #8

?

You’ve installed it: Ok

You’ve set your pythonpath

The Blender console should say:

Using Python version 2.4

or

Using Python version 2.3

instead of

Using Python version 2.3
'mport site' failed ; use -v for traceback
No installed Python found
Only built-in modules are availible. Some scripts may not run.
Continuing hapily. 

Then all you need to do, is to open a .py or a .txt file in the text editor and press [alt]+[P].

and voila.


(guitarplay) #9

well… i wish thats what it did, but it still comes up w/ the error message on the cmd propmt???. Whats wrong


(guitarplay) #10

can anyone help me, i cant even find the info button. Someone has to be able to help me with.

God i hate this


(Fligh) #11

The Info window is just another window but it is now called the “User Preference” window. You can get to it thru the window menu icon (far left of every window header) or you can drag it open from the bottom of the header bar at the top of the screen (which, BTW, is the header bar of the Info window, hence the big, bold “i” in the icon).

This is for Windoze, so if you have another OS you’ll just have to figure how to get to the same doodads:

Control Panel, System, Advanced, Environment Variables. Here you hit “New” and fill in the path to the folder where your Python install is (the one you downloaded from python.org)

%<


(guitarplay) #12

wtf, it wont work, why is it, that there is no python window in the user preferance widow, becuse thats where im directed. Does the version- type of python matter, maby thats my problem.


(Alex_G) #13

Use 2.3 for Blender 2.3x or 2.4 for Blender 2.4 Alpha.


(guitarplay) #14

YAY IT WORKS. i just needed the right python, so now i dont get that error, but i got the same problem

i get the error whenever i try to export as a mdx.

i tried installing it on a computer at my school, and it worked fine??. I dident get an error, but it just plain out dident convert the files i wanted it to, I hit convert to .mdx and it changed the screen and all, but it never actualy created any mdx file?? thats kinda weird


(guitarplay) #15

AHHHHH CAN NO ONE HELP ME

i dont know what to do and im realy pissed off. Please tell me what i need to do. Anything, im realy getting frustrated!!!


(Alex_G) #16

find a say… .obj to mdx converter

try here:

http://www.infoceptor.com/custom/warcraft3/tutorial1/

Use Blender to export to .obj then use the external app to convert it to mdx


(guitarplay) #17

I HAVE AND I DONT UNDER STAND IT !!!

it wont let me iport it and its getting real real real real real real real annoying, im having someone do it for me, but i havent heard bak from them, and id rather be able to do it myself!!!


(guitarplay) #18

WHAT STILL NO ONE CAN HELP ME i mean come on this is getting a little bit crazy man :frowning:


(LetterRip) #19

guitarplay,

copy everything that ends in .py into your blender .scripts directory that came in the folder that you downloaded. (including the stuff in /warblender and /warblender/mbx ) it looks like you just didn’t copy some of the files into the directory.

Then run the exporter from the exporter menu. The documentation that came with the exporter is pretty poor.

LetterRip


(guitarplay) #20

been there done that bout like 8 different times. . . but if im gonna do it again im gonna do it agin. . . AHHHHHHHHH