Warp problem

Hi all,

This question might have been asked before but I couldn’t find it before. I was reading this chapter:

http://mediawiki.blender.org/index.php/Manual/Basic_Mesh_Tools

When I got to the end and succesfully made the first 3 short tutorials, I came uppon this problem. When I warp the text it becomes mirrord instead of the normal order thats also shown on the picture. Could anyone help me with this problem? :confused:

Thanks,
Patjo

That’s an anoying thing with warp.

My advice is:
Open two 3d windows, the other is to see your text in front.
put your mouse near the cursor (warp center point) before SHIFT+W. Now move your mouse in oposite corners of the 3d window (you can see the result in the other window).

There is a couple options:

  1. You can do a negative warp effect.

In edit mode, start with your mouse cursor located towards the top of your screen,
Press Shift_[w], and
move your mouse cursor downwards until you see a value of about -320
in the 3DWindow header.

alternatively, after you’ve started the warp tool, you can just type in
-320 (using the number buttons above the main keys on your keyboard).

  1. Mirror your text and then use warp.

In edit mode, press [m] > Global X axis.
then apply warp of about 320.

Thank you both, all the options work but after the warp I get those nasty lines in the mesh. Is there an option to get that nice and smooth?

Try to clean your mesh letters first. Convert to quads, subdivide, etc…

I did subdivided the mesh twice but that doesnt seem te work. Ill try to convert them to quads. Thats being done by merge the vertices right? sorry im still a beginner:rolleyes:

To convert to quads (1 face with 4 edges) you select the faces to convert and press ALT+J (normals have to point the same direction (CTRL+(shift)+N to recalculate normals outside or inside, respectively).
You also have a script that give (most of the time) better results, you find it in Mesh scripts and is called “triangles to quads”.

I don’t know how you plan to do the warp but, as an example if you make it from top view and the letters are made in front view, i think it will be good if the faces are arranged in a vertical position.

There’s another thing, the text resolution (F9), Curve and Surface panel. This value control the number of subdivisions (among other things) you get after you convert it to mesh.

I don’t know if i explained myself very well, but if you need more help with this post the font you’re using and the warp value you intend.

After converting to mesh, it helps to perform
a few ‘beauty fills’, ie. press Alt_[f] a few
times (until the beauty fill no longer adjusts
any edges).

What this will do is rearrange the edges of
the text so that you don’t have any long
edges oriented horizontally across the text,
which looks bad when warped.

Wow that really works. Almost all the lines are gone. But the first time when I pressed alt - j, I saw the edges moving a couple of times and I warped succesfully, but when I try now in a new blender screen its not happening enymore. Its really weard and now I get those lines again sometimes it are black lines and sometimes its just like a piece of paper you throw away in a trash can. These are the settings that I use:

Text: Warp problem

Extrude: 0.1
Bevel Depth: 0.01
Bev Resol: 2
DefResolU 6

The font type is the default that blender uses.

After I warped the text I smooth the text. Thats helping alot but I see a few dark lines after smoothing. When I give the mesh a colour like the colour red. The lines are darker red then the rest of the mesh.

Here it goes another tip. After all of the above “medicine” :), select all the faces in the front and back plane of the letters (the ones that share the same plane). Now press “Y”.
Select all faces, do the warp, leave editmode and apply “Set Smooth”. What do you think now?:slight_smile:

Actually, you shouldn’t have to use the Split command [Y]
to split the text into different pieces, as it is already split
when you do the text > curve > mesh conversion.

You can prove this by selecting a vertex on the front face
of the text and pressing Ctrl_[L] (Select Linked vertices).
The front, back, bevels and middle parts are all individual
pieces already.

Are you sure you recalculated the normals (Ctrl_n - with
all vertices selected as MADCello suggested earlier)?

My only other suggestion would be to activate the AutoSmooth
button in the Edit Buttons Window [F9] > Mesh panel
(Default setting of 30 should be fine). You won’t notice a
difference in the 3DWindow, but it should render out a bit smoother.

Yes I recalculated the normals, but I saw that you sad that if the edges are conected to the other side you get the nasty lines. So I checked my mesh again and I stil see that the edges are connected to the other side.
I performed 2 extra subdivides on the mesh and you can see it less but for example the letter E of the F you see it verry clearly.

It’s sounds as though at some point that you performed a remove doubles [w] > ‘Remove Doubles’.

I should have mentioned earlier, that the order in which you do these operations is very important. Once you’ve done the warp operation, it’s too late to try and clean up the mesh.

So in broad terms, the procedure is:

  1. Add Text. (In front view).

Set extrude values, bevel, etc.
Center horizontally and vertically. (Press the ‘Center’ button and adjust ‘Y offset’ to about -0.2).
Adjust resolution as desired. (DefResolU = 6 (or a little lower perhaps))
Conversion - text > curve > mesh. Alt_[c]
In top view, edit mode, all vertices selected; move the text “in front” of the UVSphere.

  1. Mesh clean up

Beauty fill Alt_f (3 or as many times as required)
Recalculate normals, Ctrl_[n]
Convert to quads Alt_j
subdivide once or twice [w] > subdivide
Set Smooth

  1. Apply Warp.

Note that it’s important to perform the beauty fill prior to the conversion to quads.
In fact performing the Conversion to Quads Alt_j first results in some bad geometry being formed.
(Produces an ‘overlapping’ edge).

  • refer to ‘warp5.jpg’ below.
    Experiment a bit by reversing the order to see the difference. - especially in the lower case ‘g’.

Beauty Fill First:
http://users.xplornet.com/~gimble/warp1.jpg
http://users.xplornet.com/~gimble/warp2.jpg

Convert to Quads first:
http://users.xplornet.com/~gimble/warp3.jpg
http://users.xplornet.com/~gimble/warp4.jpg
http://users.xplornet.com/~gimble/warp5.jpg

Nice little tutorial, Gimble!:slight_smile:

Wow now it works. Thanks alot both ^^ You really should post that up in the tutorial section :stuck_out_tongue: I see what I did wrong. As you sad, the order is verry imporatant and I converted before I performed the beauty fill. Its all looking great now. Realy thanks alot now I can go on with my learning progress. I just finished subsurf so first I’m making the tutorials for modeling then I go futher with curve, text and NURBS. Hope to see you both in the future when im getting better at blender :slight_smile: