Water Animation Texture Problem

So I set up this water scene and when I render, the water takes on the texture of the material that is behind it. I guess that is because of the alpha. How do I make it so it takes on its own materials instead of the mesh thats behind it?

Is It flat water like a lake? Put a second layer under the surface. It should not have the material that is behind it . But only see it . You can add color and reflection. Post a blend if this does not help.

No its actually like a fluid simulation with movements and physics and all that I just cant get a nice material. want me to post a picture?

The only way to not see the material behind is to turn off the alpha . You do know there are 2 transparencies ? z and Ray . You can use a little ray mirror for this you need to have things around it with materials on them to reflect. adjust the lights and shadows. There is a glass tutorial in this forum under tutorials. I bet the texture would be good for water

Here look at this there is glass and water but the water looks weird can you tell me whats wrong? Also I see that you cant see the water threw the glass why is that?



Never mind I got the water to look nice but I still have the problem of the water not showing up behind the glass.