Water Issues

when i set a cup or round object as a obstacle the domain falls in a box shape not the shape of the cup.
I dont kow what i am doing wrong
help ?:frowning:

The most likely issue is that your normals are pointing the wrong way.

Also, you should give your cup some thickness for a better result.
You may have to use a temporary “stand-in” cup object with really thick walls to avoid water passing through, and then replace the stand-in cup with your final cup object prior to rendering.

To correct your normals, in edit mode with all vertices selected, press [Ctrl] + [n] and confirm the prompt.
There’s an option in the Edit buttons window (Mesh Tools more panel) to display the normals also if desired.

hmmm thanks not working at all
oh well this thread is old
and unnecessary
i am wasting web space