Water - Liquid Simulation


(lococobra) #1

Ok, so after a while of experementing… I figured out how to do fluid simulation in 2.4… problem is… textures.

I tried to make my own material for the water, and it ended up looking like shiney black oil. The animation was awesome, but the material sucked.

Anyone want to give me some settings to get the water looking good? (and maybe a way to fix the transperent raytraced shadow problem)

Thanks.


(macouno) #2

what transparent raytraced shadow problem? Unless you explain the problem we can’t really suggest a solution.


(lococobra) #3

its a problem that happens when you make a scene like this
…|
…|…|
…|…|
…LIGHT.*…|…|
…|…|
…Surface.->…|…|
…Surface.->…|

(assume the periods were not there and the surfaces where flat)

Even if the first surface is completely transparent (by alpha, raytraced, or z-tansp settings) the shadow on the second surface will still show as if it is completely solid. This is of course using raytraced shadows.

My main concern is still the actual transparency settings for the water.


(Spin) #4

[/quote]…the shadow on the second surface will still show as if it is completely solid. This is of course using raytraced shadows.

My main concern is still the actual transparency settings for the water.[/quote]

This isn’t just a clear liquid problem. It happens with clear glass too. Light passes through the front, but not the back.

I figured this out “sort of”. I changed the Depth to equal the layers of clear surfaces that the light had to flow through. (And I used a photon lamp).

A windows pane has 2 sides, so use a depth of 2

A Glass mug has 4 sides (front & inside, other inside & back)

Give it a try. Your liquid probably needs a depth of 2 maybe 3.


(lococobra) #5

Hmm, yeah I tried it but it isnt working… are you doing these renders with internal render or yafray?


(Spin) #6

YafRay.

Now I am going to have to try this myself with 2.4
I have already seen a lot of changes in it, compared to 2.37a (what happend to 2.38 and 2.39?)


(lococobra) #7

Yeah, I was using internal render… and even after changing to yafray I still cant get it to work :-?


(Pseudonym) #8

do you have the “traShadow” button clicked on the material recieving the shadow?


(traitor) #9

gah, you beat me to it. took me SO long to find that little gem. i wish it was automatically switched on.


(lococobra) #10

No, I didnt have that checked, problem solved. However, I am now getting a weird outline around the shadow… guessing thats just the extra side making harder shadow?


(traitor) #11

hmmm. could you post a screenie?


(lococobra) #12

Yeah, and the red isnt making any difference to the shadow… but i think the edges on the shadow are just the added thickness.

http://i8.photobucket.com/albums/a24/lococobra/shadows.jpg

ALSO

http://media.putfile.com/Water-Goodness <— Thats the fluid animation that i made… for some reason the water moves about 1/2 speed that it should, and the coloring is all wrong.