WebGL Exporter (any script) not loading


My mind is confused and I am lost. I am trying to get something really simple working and have failed to do this over the last 3 days. I have finally come here for help!

My Objective:
Export models from blender into JSON with vertexPositions / normals / texCoords / indices. Should be simple or so I though.

What I have tried:

My first task was to find a blender 2.5x compatible exporter. Found it (https://github.com/dfletcher/yawgle)

Next I used File > User Preferences opened the addon page and clicked the shiny install addon button. It did nothing. I pressed it again and it informed me that the script has been installed. Confused that the blender console didnt throw an error, no messages poped up I decided it must be a bad version of blender.

My second task (because the one above didnt work after the 15th try)

I uninstalled blender, uninstalled python. Got the new python (v 3.2) and installed it. Got the new version of blender 2.57.1 and installed that.

  1. Attempted manual install (placed the files in %appdata%/blender foundation/2.57/scripts/addons) - this has the same problem as described above

  2. Attempted to use blenders install - the same thing occurred

  3. Opened a text file in blender pasted the python code and clicked run script. No errors were thrown and in File > Export there was a “.json” !!! yay but wait its grayed out and I cant click on it?

Im lost and cant figure anything. I have attempted to install 3 different scripts. I have attempted running Python 2 and 3 I have tried blender 2.49b / 2.53a / 2.57.1 they all did the exact same thing as described above (with the exception of 2.59b throwing an error when running the script because it was built with python 3 in mind)

Please help! Any ideas would help! Thanks in advance.

The file date on your link is Dec 2010, blender 2.57 came out in April. There have been many api changes since December so not surprised it doesn’t work. You need an export script written specifically for 2.57

So, blender does not:

  1. Warn the user that the script is not compatible

  2. No errors are thrown (using the “old version”) when run from the text editor in blender

  3. No warnings / errors are passed when a script is “installed” but does not get added?

I can fully agree with your statement because it runs just fine when its in the blender note section but it wont let you click the buttons ect?

I also have to disagree because I downloaded blender 2.53 and attempted to run this script (its true target) and got the same results?

If this is still the problem does anyone know / have a JSON 2.57.1 compliant script?