Weight Error

Hello I was trying to set up my new character in a pose using blender. I have done a few other rigs without a lot of problem… This one the mouth keeps giving me grief. Thought I had the weights all right but now I see the tongue is not following along even though the vertices are weighed to the correct bones.

It’s late maybe im forgetting something simple… Here’s a screen shot of the error.

Thanks, Z

Did you [Ctrl][P], “With Automatic Weights”? Automatic weighing don’t work well when you have hole in a mesh like mouth opening. It does some wired things. You need to weigh the tongue manually on to the bones.

It should be simple. You already have the vertex group made and associated to the bones. In edit mode select all vertices except for the tongue vertices. Hide it. Go through each tongue vertex group and hit “Select” then “Remove” button to remove all influence. All you do now is to select vertex grope one by one and manually select vertices associated with that bone and “Assign” it. Play with Weight setting for vertices sitting between bones.

Thank you for the reply ridix.

Yes I did but I also used weight painting to correct problems for each bone.

I would assume Weight painting would be manually assigning weights to each vertex… But I went ahead and tried your suggestion on working through edit mode…
Believe I followed it correctly but I’m getting some funky results…


I went in and hid all the Poly’s surrounding the tongue.


Then I Selected all the tongue’s Vertacies and hit remove for each bone under “vertex groups”. Then a few more times for the jaw… I also assigned them to the jaw as a weight of 0.00… then again hit remove a few times…


The results! tongue in a deformed way follows the jaw of course! :S


So I go to my trusty weight painting which has worked perfect in the past and shows the weights on the tongue’s vertices for the jaw bone are set to 0.00 as they should be. Also the weights for each section on the tongue is set up right with it’s nearest vertices Weight set to 1.

Well I go ahead and select my jaw bone and paint 0.0 on the tongue… magically this sets my tongue back to it’s original state…


But It’s not deformed and it’s not following my Jaw anymore! On top of that the Weights for my tongue are all still set to 1 in the fashion I manually put them in 3 or 4 different times now. SO fantastic guess assigning the tongue to the jaw at 0.00 caused some weird problems and remove did… idk… But the important thing is now it works!..


Well… that line pointing straight down is the tongue bone doing absolutely nothing to the mesh it’s assigned to. Out of my 4 tongue bones the root at the end 1 effects 1 vertex on the very back middle of the tongue.

I have retried hitting remove for them on the jaw and on the tongue bones… then going back and re assigning them to the tongue manually selecting each vertex… To get the same deformed tongue that loves to follow the jaw it is not assigned to.

I have again painted the vertex’s on each tongue bone from 0.00 then back to 1 getting no changes at all with either extreme. I’m sooooooooooooo confused as to why this isn’t working.

Check to see if you have more then one Armature modifier on character mesh. If not, quickest way to fix it is to redo parenting and weighing from scratch. Un parent rig, and mesh. From mesh object, remove Armature modifier. And, remove all vertex groups. That will clean out the whole relationship. Start over from parenting.

Your probably right, not a super long process when there are no bugs.

Just opted to do this and Im optimistic about the results.