Weight Paint 100% Red

Tutorials I have seen show the ability to have vertices all Red in Weight Paint mode, as in

But when I try it, I get Yellow and Green at the edges, l as in

When I choose vertices, as in

and assign them Weight = 1.00 they show up in Paint Mode as Red flanked by Yellow and Green bands, as in

Surely Paint Mode should be showing only Red?

I guess your mesh has a subsurf mod…

Green is how blender shows a half-weight vertex. Your subsurf mod is creating another vertex between a vertex that is red, and a vertex that is blue.

None of this is a problem. My recommendation is that your subsurf mod should be after your armature model, but either way it won’t cause a problem.

One way to force all of the verts in a part of the mesh is to pick one vertex (Weight Paint mode with vertex select mask enabled), look at its weights under Vertex Weights (n panel) delete all bone groups you don’t want, set the one you do want to 100%, then click Normalize. Then select all of the weights that you want to match, then select the vertex you fixed, and click Copy.