Weight paint breaks on my rigged mesh after saving the file

Hi everyone, I couldn’t find anything online similar to my problem, hope someone can help.

I have a rigged body from MB Lab, I deleted the head mesh and replaced it with my own. Of course, now the weights of the missing mesh are gone, so I repaint the head and neck, and the rig works perfectly.

When I save the file and re-open it the weights of the whole mesh are scrambled and ruined and the character looks deformed.

I could share the file but it will look like the second version, where the weights on the body mesh are at random locations on the polygons.

Not sure what it could be, sounds like something to do with the data in the background but I can’t fix it.

Any ideas are appreciated.

If saving then reopening bugs it, you probably have encountered a bug in Blender. If you can recreate the bug, you might consider opening a bug report on the tracker.

You might consider disabling all addons/scripts before saving (if the window’s still open.)

With a file, people might be able to tell you more, but that doesn’t necessarily mean that they’d be able to fix it.

1 Like

Hey thanks for replying.

I disabled all add-ons but I still get the same issue.

A work-around I found is to append the skeleton and mesh to an empty Blender scene and that imports the rig correctly. If you just open the Blender file the weights are corrupt.

That’s definitely a bug, and I’m assuming it’s related to MB-Lab and not necessarily blender cause I can’t recreate it with regular blender objects and bones.

I attached a file that has this problem, if anyone can open the file correctly, I guess it means that my copy of Blender that’s problematic (Although I did try downloading older versions) and if you still get a corrupt rig you can append it in a new scene to see the correct form.

Test_Suzanne_03.blend (2.2 MB)

The weights in the file you linked look roughly like what they should be, not like your pic:

1 Like

So that narrows it down to a problem in Blender installed on my machine. Thanks for checking it out, I’ll look more into it, but I know at least I can use it by appending it at the moment.

1 Like

Same bug here. It looks like any editing of a MB-Lab mesh triggers it, but only upon re-opening the file. I tried to boil it down to the simplest possible example:

  • Extrude a new face on the right upper arm, that new face get correctly assign to the vertex group upperarm_R automatically.
  • Save the file, close Blender then re-open the file.
  • The new face isn’t part of any vertex group anymore.

Like you mentionned, when appending or linking the mesh and armature into a new file, the bug doesn’t show up. But then the bug comes back after saving that new file and re-opening it, so sadly it’s not much of a workaround.


I’ve just ckecked now, and the bug shows up in 3.1 and 3.2 but not with 3.0!

I think you need to use a version of Blender with compatible python versions. 3.1 and 3.2 changed slightly and MB is in python. Just a guess since I don’t have access to your files. Check the python versions in both MB and Blender and make sure they are the same.

1 Like

Good theory, but I don’t think that’s the case here because the 3.1 version I was using when I first saw the bug was an old alpha still on python 3.9.7 which is the same as in blender 3.0

What version on MB labs?

It’s MB-lab version 1.7.8.50. Somehow I’m not even 100% convinced this bug has only to do with MB-Lab. Thing is, when I append the armature and the mesh into a new file then save, 3.1 and 3.2 mess up the weight paint upon reopening but 3.0 doesn’t. And at that point I haven’t even used MB-Lab in that new file.

EDIT: Actually I was wrong, it has to do with MB-Lab. I think the reason 3.0 is fine is because the addon wasn’t installed.

EDIT’s EDIT: Big Meaculpa, I think it was my fault all along. First time using the add-on and I hadn’t realised that MB-Lab has a “Finalise” option. Since I hadn’t done that, it would make sense that MB was freaking out with me editing the mesh.