weight paint issue...

Say hi to Bob :), he’s a hand puppet
I’m having an issue with moving the neck around. instead of moving fluently it kind of waves. Anyone know how to fix it?

I removed the hair in the file so it could be uploaded.



bob the puppet1.blend (290 KB)

Hi Billt Joe,

I couldn’t figure out what you meant by the neck waves, then I saw what you meant. First, to see what is happening, go into Pose Mode, rotate the head forward. Then select the mesh in Object Mode, go to the armature modifier and turn on all the boxes to the right of the modifier name, (the last box, “Enable Modifier During EditMode” wasn’t selected in the posted blend). When you select that box, a new circle will appear to the right of that, click on that circle, then enter Edit Mode for the mesh, now you will see how rotating the head affects the vetices.

Basically, you have too much weight paint applied to the neck vertices. In weight painting you can select the amount of paint to be applied. No paint is blue, all paint is red, 3/4 paint is yellow, 1/2 paint is green, and 1/4 paint is cyan. You can control how much paint is applied in the weight paint panel under the Weight area, there are settings to apply less paint. But since it’s painted, you may need to choose the Sub button on the right to remove paint. You’ll have to play with it, it’s something you have to learn.

BTW, move the armature modifier up in the modifiers panel so it’s above the subsurf modifier. That way, the armature modifier is evaluated before the subsurf modifier, meaning the mesh is deformed by the bone before the subsurf does its thing.

Hope this helps,