Weight paint problem

Hi. I’m rather new in weight painting. Why is every painted vertex behaving like it has 100% of influence?

A vertex needs to be assigned to two or more bones or it will move 100% with the bone it is assigned too, regardless of its weight.

So, if the vertex only has weight for a single bone, it does not matter if that weight is 1.00 or .001, it will move like it is weighted 100% (1.00).

To fix the issue, add a small amount of weight from a neighboring bone. Also, use Auto normalize so all weights on a vertex equals 1.00.

If you do not normalize the weights, you could, in theory, have a vertex assigned to 100 bones with a weight of 1.00. In weight paint mode you would think it has 100% influence from one of the 100 selected bones because the color is red, but in fact it only has .01 weight from that single bone and .01 weights from 99 other bones. Blender will normalize the weight internally, but it will look red in the viewport, giving you a false sense of the true weight value and the effect of those weights.

I know that sounds like a bunch of mumbo jumbo, but there it is…

Auto Normalize your weights and assign at least a little weight from neighboring bones.

Good luck!

Thanks, i get it, but when i check “auto normalize” my brush isn’t soft anymore. Can i fix it somehow?

I’m not sure. Check the Options tab and look for Unified settings. There should be options for Size, Strength and Weight. This should keep the setting from one brush to the next. I’m not sure why/if Auto Normalize would change the setting of a brush.

Are you sure you did not just switch brushes?

Here’s my video showing the problem:
https://www.youtube.com/watch?v=avYcwOlAt6Q

I did assign arm’s vertex to the forearm with 0.054 of intensity with no result. Were you typing about this?:

I think in your situation, you should parent with automatic weights and refine the weights from there. It will be easier until you get the knack of weighting.

Select the mesh (Object Mode) Shift Select the armature (Armature should be in Pose Mode) CTRL P, Automatic weights.

Be careful that only bones that should deform the mesh have the deform option checked in bone properties. For example, if you are using IK constraints on the arms and legs, uncheck deform for the IK target bones or any other mechanism bones.

Good luck!

Edit: If you upload a blend I can take a look and make sure there is nothing else causing the problem.

The problem with automatic weights is that blender stops working when i try to do that. It’s my first model ever and i think i did wrong by applying all subdivision surfaces and multiresolutions (over 256 000 faces, it is a lot, right?), so there’s no memory for the automatic weights operation (though i have 8GB RAM and 4x 2,9 GHz).

But what exactly do i do wrong? Are those some bugs or what?

So i did assign vertex to 2 bones: arm and forearm:


Yet it doesn’t solve the problem. Arm’s vertices still move like they are assigned with 100% of influence, yet they are green on the eadges, so why do they behave like they are all 100%?

It’s harder to explain then fix.

Before you go any further, you need to fix your mesh and bring down the face count. There will be no end to your grief trying to weight paint a mesh that dense. Do you have an older saved version of your mesh without the applied subdivisions and multi res? If so, load that up and continue your project from there.

It’s possible that you could use the decimate modifier to decrease the face count. I would not rely on it though. I’ve found that it often destroys the mesh or decimates the wrong areas.

I don’t know what else to add as far as advice until you get a lower poly model to work from.

Good luck!

I managed to solve the problem. First i assigned 100% of character to one bone (with hard brush and auto normalize on). It seems that it fixed my brush somehow, so it became soft once again when i start to paint other bones. Mesh moves fine according to its weight color too. No decimation needed. Thanks for your tips, mate :slight_smile: .