Weight Painting: anything above 0 treated as 1

Found the problem! See 2nd post, move this thread if needed.

Asked in #blender and was suggested I submit a bug report, but thought I’d check here just in case.

I created a cube, attached a two-bone armature to it with ctrl-p > armature > namegroups. Then I made it into a real modifier. After that I went bone by bone to weight paint a few vertices.

You’ll notice if you open the blend I posted, that one vertex will be light blue, the other will be red, yet the armature is pulling them as if they were both red.

Whats more, I can’t seem to activate its action in the game engine (Yes, start and end say 0 and 0 in the action modifier, change that to 30, you’ll see it’s still no effect ^^;; my mistake for that one). Is there something blatantly obvious that I might have missed, or is this a bug?


weightCube.blend (137 KB)


<Intertricity>Hey, #blender suggested this might be a bug, was wondering if anyone would mind taking a look at this supposed weight painting bug -> http://blenderartists.org/forum/showthread.php?p=1210163#post1210163
–>|zaghaghi ([email protected]) has joined #blendercoders
<z0r>Intertricity: without looking at the file, if a vertex is only influenced by one bone, that influence will be 100% regardless of the weight
<z0r>weight painting only changes the influence when there is more than one bone affecting the vertex
<Intertricity>z0r: oh wow, I just created a third bone as a root and assigned it a weight of 1
<Intertricity>thank you so much this has been killing me for HOURS
<z0r>Intertricity: :slight_smile: np
<jesterKing>Intertricity: make sure you write the solution to your problem to the forum, too
–>|sill ([email protected]) has joined #blendercoders
<Intertricity>Okay, I’ll do a paste for that :slight_smile:

So I created a root bone that was assigned to all vertices with a weight of 1. It then worked. ^^


weightCube.blend (138 KB)