Weight Painting HELP

Hey Guys,

I have moved a file over from a cad file. It is extremely detailed, but I have done mesh cleaning, etc… So each individual piece of the machine is it’s own mesh. I have joined many of them to just make “blocks” of components as opposed to having every one singular. So I have a 200 mesh down to about a 6 mesh. I am trying to put a bone in each mesh so that I can move each piece individually.

When I do this, and I put the bone in, it won’t move the entire mesh. Vertices stick in the place they originated. The solution is weight-painting each face, but since they are so detailed, I spend 20 minutes spinning the mesh around in object view, painting the things I can’t see.

Is there anyway to apply a uniform weight to it?


Your question is a little cryptic.
So you have 200 objects, but you’ve joined many of them so now you only have 6, and you want to move these 6 pieces individually, right?

Well in that case simply go to pose mode for your armature, select the object you want deformed, shift select the bone you want to do the deforming, press ctrl P, and select ‘Bone’.
Now moving the bone in pose mode will move the object too.

Is that what you’re asking?

fantastic, that worked brilliantly. I am now only having the following problem. I tried to export it for use in XNA via the directx8 exporter. I am getting the following error message from the blender console.

File “C:\Documents and Settings***\Application Data\Blender Foundation\Blender.blender\scripts\Directx8Exporter.py”, line 770, in writeTextures for face in mesh.faces:

AttributeError: ‘Armature’ object has no attribute ‘faces’

I tried doing the fbx export optimized for xna

it exports ok, but then xna gives me the following

"Multiple skeletons were found in the file. The first skeleton, named “Bone” has been moved to be a child of the scene root. The other, “Bone_0”, will be ignored.

“Error normalizing vertex bone weights. BoneWeightCollection does not contain any weighting values.”

any help?

Again, I have one big bone in the system that acts as a base, then several disconnected child bones throughout the model. I have tried multiple times to parent the child bones to the base-bone, but it doesn’t appear to be working as when I go into edit and look at the properties it says “child of” but then is blank.

I can’t help you with your export problem, but I think I know what’s wrong with your bones.
My guess is that you added 2 armatures, Bone and Bone_0, and each of them contained only one bone.
A better way to do it is to have just one armature, named Armature or something, and add both Bone and Bone_0 in it. Then you should be able to parent them without difficulties.
An armature is not a bone, it’s only a collection of bones.
This may be what’s wrong with the export, although again, that’s over my head.