weight painting in 2.49b

http://www.darkscarab.com/tutorials/archive/view.php?title=Billowing Flag

NOT the pdf download - the onscreen version.

“If you hit Alt+A you will notice the wind working as your flag flies off into the distance. Let’s make the flag stay in place. Select the flag and go into Weight Paint Mode (This is in the pull-down tab with Object Mode). Hit F9. There should be a panel labeled ‘Paint’. The Paint tab is shown below.”
i do not see any paint or weight paint option
where has blender hid it now?
thank all

Your link is broken, here is the correct one.

See attached image for weight paint mode location.


thanks for your help

If anyone knows how to make this work like in the tutorial - i would love to know it!
the flag vanishes only after 250 frames or so, then the next time it goes away immediately - maybe there is a refresh key somewhere so it forgets!
and the painting changes color okay but otherwise does nothing!
what am i missing?
i wish tutes worked- just once!

See attached blend, look at the cloth panel especially at pinning of cloth.
Hit alt-A to see the motion. If still stumped ask again. (I’m at work so I have to rush my answer)
If you look on the collision tab you will see the bake time is set to 250. If you need more frames, you will need to increase this.


flag.blend (184 KB)

. . . . …

thanks very much
note the tut was for 2.49- i am using 2.49b that was part of the problem
and i suspect the flag was waaaaay tooo small - blown away by the wind.
i will look at the file tonight
thanks again

thanks for the file
" look at the cloth panel especially at pinning of cloth". what exactly am i looking for?
this flag is great!
weight painting - can it be removed and started again or is it amendable?
i assume that is how it is pinned.
thanks again

Here, have a look at this link:
And actually, reading that entire web page would be a good idea to gain an understanding of what is taking place.


In response to your PM.

I will have several flags, so can they each have individual winds?
so the wind only affects one flag each?

Yes just seperate the empties and flags on individual layers. See attached blend.


2-flags.blend (179 KB)

thanks very much

thanks but that don’t seem to work - when i try it
see attached.
some layers have no wind - but the flags blow
i selected view all layers


8-LAYERflags.blend (235 KB)

Seperating them with layers certainly does work. In the attached file, you will see that the flags are all on seperate layers, each with an empty. The flags are blowing in opposite directions!! The one on the top is blowing slowly because the strength is low.

IDK what you mean by the flags still wave. In your file, you may need to free the cache on the cloth under the collision tab. You do understand that even without wind, any mesh with cloth activated will move and sag because of gravity.

It works perfectly on my end. IDK what your final purpose is for this, but if you are struggling getting it to work all at the same time, just do each flag seperately and render with alpha then composite them together.


flags.blend (196 KB)

thanks for your help
free cache did it!
the goal is to have 8 glags rippling a little.
each will have a video in them.
so only a little ripple so the video is ‘viewable’

11mg file 25 frames.
non moving part of the flag is a little too wiggly!
all copies of first flag.
BTW my media player wont play it - pinnacle does.