Weight painting not working (so it seems)

This is probably a noob question (since I am one), with an obvious answer, so sorry for that.

I am trying to follow a stickman rigging tutorial step-by-step. Some of the bones do not deform the mesh in the way I would like them to exactly, so I decided to go into ‘weight paint’ mode using the following steps:

  • Go into pose mode and select a bone
  • Shift-select the mesh
  • Go into weight paint mode

I understand that I should now see my mesh, color-coded according to the local weights. However, I do not see my mesh, I see only the bones (see attached figure). The only thing visually different are two yellow lines (also visible in the figure).

Does anyone have a clue what is going on here? Am I missing a step or setting? I am running Blender 2.66.1 on Ubuntu, by the way.


Can you upload a .blend file?

Try not using Shift-Select when selecting the mesh for painting. Selecting the armature and putting it into Pose Mode is necessary, but using Shift adds the mesh to your selection and that is probably making Weight Paint mode impossible. Only the mesh needs to be selected to do weight painting.

Once the mesh is in Weight Paint mode, you can then select the bones to highlight the areas of influence to be painted. The rig has to be in Pose Mode for that, which is why you set it that way before entering Weight Paint mode on the mesh alone.

You can also select vertex groups to paint to in the Mesh Data panel, since they correspond to your bones.