Weighted vertices dont move??

Ok so i have a model all rigged and im just finishing up the rigging details to make everything work perfect, and all of the sudden the weights i did earlier arent moving with the armature. They are still painted exactly the smae as before, but now whenever i move the bones, a couple vertices will not move, even tho they are clearly weight painted. Also when i click on some of the bones it shows the opposite side with magenta painted on the vertices that wont move, for example, i select the Left arm bone, it shows the weights but on the part where the Right arm bone is weighted, it shows magenta painted verts, and they are the ones that wont move on the Left arm, and vice versa. but sometimes it doesnt show the magenta vertices. I tried subtracting the weights from the vertices that wont move, and then re painting them, but they still dont move, is this an easily fixed problem??

What’s the rig look like? Are you using Rigify? Are you sure you’re trying to move things with the bones that are meant to move them?

I’m asking this because Rigify (as a for-instance) has MECH bones, DEF bones and CTRL bones, more or less adding up to three complete skeletons. I’ve gotten myself confused a few times and tried to move either MECH or DEF bones which, of course, doesn’t work.

no im not using rigify, im just using the normal old blender armature, which only has the one bone for whatever. Well its basically a normal human shaped skeleton, 2 arm bones 3 finger bones 2 leg bones, a couple back bones, head, whatever. It all worked perfectly before it just all of the sudden stopped working. Also another thing i noticed while trying to fix it myself was that i could add more magenta wights by using the blur brush. And now that ive been messing around with things it does turn out that the magenta painted weights are the ones that refuse to move. Say i select a bone, then somewhere else on the mesh there are some magenta painted vertices, they do not move, even when i grab the entire skeleton and move it the vertices stay put.

Can you post your .blend file?

Of course, here is a link on mediafire because idk how to post them directly… or can u even do that? whatever, here it is: http://www.mediafire.com/?gu96z270z69298j

ive never had this problem before, maybe i accidentally checked something i shouldnt have

has anyone even had this problem before? i know i found another glitch that no one had seen before when 2.63 first came out… i hope i dont have to restart, i sat there and weighted everyting by hand, i didnt use automatic weights or anything X0

I checked the file and the only thing that isn’t weighted is the ribbon thing on the head, which isn’t weight painted all the way through.

When I tested it in an older blender version I got the same problem you are having. Some vertices seem to have a broken weight. Selecting a vertex, box selecting the other bugged ones and typing 0 and pressing Copy in Vertex Groups at the n-panel fixes this, but you could try opening the file in a more recent build of blender first.

Thank you so much, i figured it out… even tho i wasnt really sure what u were talking about, i went into weight paint mode, clicked vertex select, and selected the magenta vertices and then went to the object data tab and removed them from the vertex group, now everything works perfect again, so glad i didnt have to start over