Weird and specific problem playing back any video file.

Here’s a really strange problem I’m having with my computer. First let me start with a rundown of my system.

AMD64 2800+ on a chaintech K8T800 MoBo.
512MB DDR3200
Pny FX5200 128MB video (ver 61.77 nvidia drivers for XP)
Win XP sp1a (installed sp2, had a problem with a program and uninstalled sp2)
Soundblaster Live
DirectX 9.0c installed
WMP 10

Okay, here’s the problem:

When I play a video file (in windows mediaplayer, quicktime 6, NVDVD, Mediaplayer classic, or DivX player) the first time it will play just fine. But when I try to play another video file I get 2 seconds of video, then a solid
green screen on the video with audio playing normal (quicktime audio stutters). And every type of video file I play after that does the same thing no matter what format (AVI, MOV, MPG, WMV, etc…) or player I use.
I have tried so many things it isn’t funny, but I believe I have narrowed it down to hardware accelleration in video playback involving Directdraw and Direct3D. I say this because if I turn accelleration off in the windows performance setting, I can play any video, any number of times, without problems (it looks like crap though). I can’t leave it like that because then my D3D games don’t run right.

I have the latest video drivers ( I even tried older 56.XX series video drivers with no success), directx, windows updates (except for sp2) and at some point over the last 4 months I didn’t have this problem. I just can’t remember when it started, so I could not say it was just after I installed a certain program or codec.

Everything works great, my games, my programs, etc… except for this one thing.

I found a strange workaround. By changing the refresh rate, I fix the problem for that particular video that I’m playing. It doesn’t fix it to switch to another refresh rate and stay there, it just works when the rate is changed. Then the next time I want to play a video and it messes up, I change the refresh rate again. Now I just go to change the rate, when it asks if I want to keep this rate, I say no, it changes back and my video

Pretty strange? Now, how do I fix it? Could it be a hardware problem? Or XP sp2 (you know you can never completely uninstall updates from microsoft)?

Google was no help no matter how many ways I tried to word my search.
I used the driver cleaner program when changing video drivers but still no help.
My anti-virus is up to date and found nothing (AVG by Grisoft for those who want to know)
I have defragged my drive.
I have scandisked my drive.
I installed Norton Utilites and ran Windoctor (it found and fixed several errors, but none helped this

I ran DXDiag and checked my DirectDraw and Direct3D performance, works great.
I’ve Uninstalled codecs, re-installed codecs, changed setting on codecs, still no help.
I have Adaware and Spybot S&D, no ad/spyware problems
ZoneAlarm is my firewall (has been for a long time).

I’m going down this partial list of stuff I have tried to show that it is not some simple “update your drivers”

kind of problem. I would hope it is a “hidden settings” issue that someone could clue me in on.

I am about to slick my drive and do a clean install, which I really don’t want to do. Its such a pain in the

ass, and my computer is set up the way I want it. But I’m not sure how much longer I can stand this.

Please help.

I’m curious

have you tried winamp [5] and turning off harware overlay?

I have no idea why it would mess up though…

I don’t even have winamp on my computer. I don’t think its a media player issue. All these other players worked fine at one time not too long ago (as in a month or 2). Thanks for the reply though.

system restore might be worth a shot. 2 months is a long time to roll back to though.

what codecs do you have?

you say you uninstalled then re-installed them. but the combination of codecs could be the issue.

do you, or have you ever used a “codec pack” these have been known to cause issues as more than one codec is trying to decode the same file at the same time.

i suggest getting.

FDDshow Filters
(the one filter decodes these formats)

they decode ALL of those formats (WMV up to a certain version) and its not a codec pack, it decodes with about 30% saving of CPU power compared to the individual codecs. (DivX)

That and the DivX codec (for encoding video) along with an AC3 filter for decoding 5.1 channel sound and you will be able to play all video formats under the sun (almost)

i don’t know if that will solve your strange problem, but it could.


Refresh rate is alot more crucial than people think. Most videos play at 25-30 frames per second, so if it’s 25fps and you have a 75hz refresh rate, your system has to send info to your monitor, ‘render’, each frame 3 times. This is why alot of video games default your refresh rate so low.

As far as your problem, I’m willing to bet Alkaten is right. I’ve done more than one codec clean up to clear problems.

Have you tried updating your video card drivers? That is indeed a very strange problem you’re having.

PlantPerson - I have the latest drivers, I even tried older drivers.

JordanAU - I do not use System restore, I loathe it.

Alltaken - I don’t believe it is a divx codec problem because I’ve had Divx on for a long time before without problem. Plus my problem is with ALL video files, not just avi’s. Any .mov, mpg-1, mpg-2 or avi (even my DVavi’s) in any media player does the exactly same thing.

Enzoblue - It does not matter what refresh rate I have it at, it still does the same thing. The act of changing refresh rate is what fixes it for the video I want to play. Thats why I think it may be a hardware problem.

Thanks for the effort, I have tried all those possibilities already.

I pretty much have decided on 2 things left to try

Reinstall SP2
If that doesn’t fix it then do a fresh XP install

If that doesn’t fix it, then I feel confident its a hardware problem.

do you have a DVD software package like PowerDVD or WinDVD installed?

if you have one installed try uninstall it, also if you don’t have one installed then try install one.

the final fix for the problem is probably somthing really really stupid. somthing so obviously dumb its not funny (its like that with everything)


I have NVDVD installed with its update. I guess I can try removing and reinstalling it.

By the way XP sp2 didn’t change a thing (except giving me that annoying security center).