Weird Black and transparent spots on render?

Can someone explain what this is?

PIC: http://postimg.org/image/4n6m30dj1/

I do have a sun lamp in the scene and have Ambient Occlusion and A little Environmental lighting on also with Blender Internal.

Here’s a way better image to show the problem and i have “gather” in environmental settings with 10 samples.

Better Pic:http://postimg.org/image/fx2i7wsgf/

Are you using the CPU, OpenCL, or CUDA?

It looks like it could be a GPU driver error, do you have them up to date?

This is a CPU render because I completely render with Blender Internal which doesn’t support GPU, does it? But I am also using Linux with the proprietary NVIDIA drivers version: 304… Woops. Latest is 340… I’ll try with new drivers and I’ll be back and if that doesn’t work, I’ll try on my Windows Laptop

So it is BI you’re using then?

Then the driver thing might not be to blame at all, it looks to me like it could be its raytracer failing to calculate the various materials properly.

Try checking the material setups for things that may be causing extreme values (especially important if you’re using a node setup), it might be something like the blending mode being used for the colors.

My grass materials are default from Mineways and all the leaves have are an alpha field. I have made no nodes. What values should I exactly be looking for.

You generally do not want to see values over 1 or below 0 in any of the color channels.

Then again, I don’t think Mineways should create those types of materials so the error might actually be a bug in the Internal Renderer’s raytracer.

So apparently the ray shadows from my sun lamp causes this. Any ideas?

Lol what a coincedence Check the times of our last posts. both 9:47

It depends, try rendering the scene without raytracing and see what you get.

Well I rendered without any ray shadows from sun lamp, no sky or atmosphere settings on and here are the results. A.K.A: Perfect
But I need the shadows to get this half-decent looking

Before (with raytracing shadows):


After(Without raytracing shadows from Sun Lamp):


I have figured it out! Apparently something changed all the textures spectacular to black. Thanks for all your help! :smiley: