Weird Black Lines On Displacement

Hmm…
How do I upload a .blend file on here?

Oh, it turns out it’s too big to upload.

How big? Inside “Save as” interface, are you checking “Compress” box on the bottom left?
http://pasteall.org/blend/

Share the link here when it finishes uploading.

Do not pack HDRI. We can use our own lighting. I guess that takes most of your .blend.
Also, check “Orphan data” in outliner and purge unused textures.

Here’s a link to the file on megaupload.
https://megaupload.nz/u7cfSah7n6/ROCKTEST_blend

First things first :slight_smile: If you are forced to compute on cpu only - use 32x32 tile size. Large tile sizes are good for GPU. But that’s for 2.79b. 2.80 has best performance on 32x32 even on gpu in most cases.

As I can see your height map texture has quantizied levels. Your color gradients are banded.

If you look close you’ll see that it’s not smooth.
Here’s with higher contrast:


In higher subdivision your faces are small enough to pick one of those shades instead of estimating value between them.

There are some methods of removing banding in photoshop, but that will be hard.
Even though your height map is 16 bit - it has been done in a wrong way. Possibly created in 8 bit mode and just saved in 16 bit depth.

TL;DR:
@Ben_Morrison was right.

1 Like

Oh, ok, thanks for the help.

I think that the problem with these black lines is mainly due to the poor quality of the displacement map. Is it the original quality of the image? Have you modified it in any way?
I think you should have better results with better displacement map images, even with 8-bit jpg.
For example, this is what your displacement node looks like with this tiny jpg:
https://unigine.com/images/news/procedural-content-generation/_612x398_crop_top-center_100/22_oilrush_rocks_heightmap.jpg


I’m not sure about why Adaptive subdivision is producing those holes
image downloaded from here:
https://unigine.com/en/articles/procedural-content-generation

The only modifications I did was add some moss and change the HDRI, other than the adaptive subdivision.

Sorry for not having explained me better. I was referring to the displacement/height image that you used. I was referring to if that was the original quality of the file that you downloaded from gametextures.

Both the 2k and 4k versions are the original I downloaded.

It’s caused by the fact that adaptive subdivision does not support UV subdividing, and in-between estimating, so if you have 2 materials or UV seam - they won’t be ‘connected’ between two levels.
I’m waiting for that option for quite some time already to create a cave with fillars with adaptive subdivision. :slight_smile:

2 Likes