Weird deformation mess up in the game engine

I have this weird armature deformation problem that is really annoying!
Ok, here’s a screenshot of the deformation in blender (not the game engine) this is how it’s suppose to look like:


An this is not how it’s suppose to look like, you can see is was some weird places where it seems to deform badly or like the mesh is made badly:


It kind of looks like they are inside out in some places, and I’ve tried to re-rig it (with bone heat) and it didn’t work… I tried to make all the normals stay on the outside, that didn’t work… The areas where it messes up is on the legs mostly

Do you guys have any ideas?

Attachments





You should re-weight paint it.

It might be triangulation- the way quads are broken down for the game engine is different from the way the normal 3d view breaks quads down, so try manually triangulating problem areas (I could be way off base here though)

if you can isolate the problem, uploading a .blend for us to take a look at would make it a lot easier to help (I’m not gonna try to make you upload that model, in case you’re afraid of people stealing it)

Oh, I’m not afraid of people stealing it, that’s ok, here I’ll upload the model… Even if someone steals it, what I don’t want to upload is my game release until it’s done :smiley:

Anyways, here’s the model:
The .blend is off…

Plus, I don’t think it’s sellable anyways xD, saying that I don’t mean it’s a bad model, but I think more out there are looking for a more realistic model and texture, it suits my game perfectly :slight_smile:

ps: Please don’t steal the model anyways, I’ll make me sad :frowning: lol

Oh, I see the problem- you have the face drawmode set to alpha, the graphics errors you saw were the mis-sorted faces showing through. Just set the face mode to opaque and you’re set. (go into edit mode, select all the faces, go to the Texture Face panel, hit opaque then copy, in case you didn’t know how)

Wow, it worked :confused: I can’t believe I missed that 0.o Everyday I learn something new, and I guess that’s that’s cool, I can’t believe it was fixed that easily… :confused:

Thanks a lot of the help, and I’m going to take of my .blend now :slight_smile:

Bye,
Linkxgl