Weird difference in rendering results between Mac & PC.

I’m getting a different result between PC and Mac release builds of 2.71.
I only have CPU rendering on the PC, but the Mac has a consistent result for its GPU & CPU renders.
(*) I have another PC I can try later, it’s just not set up at the moment.

Does anyone know what’s going on? User error? Bug?

.blend file

Mac ( GPU&CPU )


PC


Cheers!

There’s definitely something fishy going on with motion blur in 2.71 for Windows. I’m using 2.71 x64 “zipped” and with motion blur enabled Blender doesn’t render the cubes at all:

2.71 x64 zipped


2.70a x64 zipped


As soon as you turn off motion blur in 2.71 the cubes reappear.

Something similar seems to happen in your case: the cubes are partly transparent - you can see the edge of the ground plane shining through in the upper half.

I’d say: Bug it.

EDIT:
I just tried the latest Blender buildbot version from today and get those weird half transparent cubes seen in your render. So, obviously there already has been some bugfixing (2.71 “official”: no cubes / 2.71 buildbot: transparent cubes) but the result is still unsatisfactory…

Yes, it does look like they’re semi-transparent. Just tried renders both GPU & CPU on my other (clunky old) PC and got the same weird effect. I guess it needs to be bugged…

(All versions I’ve tested are x64, haven’t tried 32 bit versions)

Have you reported the bug to the developers JiggyWig?