Weird glitch

A friend of mine handed this to me earlier today. There are doubled vertexes that aren’t merging, and a ghost mesh that vanishes when you go into edit mode. Neither of us could figure out what had gone wrong. Could anyone tell us?

andymodel.blend (551 KB)

You have some hidden geometry.

In this order.
First: Open the andymodel.blend file

  1. Go into edit mode.
  2. Press " a " to deselect everything.
  3. Press " ALT-h " to " un-hide vertices.
  4. Press " x " and select delete vertices.
  5. Press " w " to remove doubles.

    That’s better.

Also… the mirror modifier slightly overlaps down the center of the model.
Still in Edit mode. Choose the mirror modifier.
Turn off tab " apply modifier to editing cage during edit mode "
Then select and pull all the vertices slightly to the left.
You will see what I mean.

Also… in the " crotch " area of the model there is a 5 sided face (Ngon), that will have to be cleaned up at some point.

Happy blending.