Weird Global Illumination Artifacts

I’ve just recently rendered this quickie of mine with Yafray renderer, and I’ve met some weird problem.

The render is done with full quality in Yafray and therefore took over 48 hours to render. :spin:

Now when I see the render I discover some, what to say, artifacts, as you can see in the attachment. Shadows are weird and doesn’t fit the polygons/models wich cast the shadows. The down-left example is the worst.

What went wrong? Shouldn’t it be nice and clean? :confused:

PS. There’s only one light source, a lamp.


Bump. Anyone?

Post a screen shot of your render settings - do you have Photon and Cache enabled ?

Here is some Yafray lighting info:-

Sorry can’t help you with Yafray but if you are rendering for 48 hours you might want to switch to Indigo or Luxrender for unbiased rendering. In you scenario I would say that it is easier and will not take much more time.

Using Full Gi without photos or irradiance cache means that you are using old YafRay Pathtracing which is not particularly fast or efficient. The whole point of yafray has been always fast raytracing. For your scene Blender will be enough.

Also about your issue, in my opinion is a light source issue, did you give radius to your point lamp or is it doubled?

Thanks for the replies, I thought no one would answer me. =)

I have attached a screenshot of my rendersettings and lightsettings.

I do not have cache or photons enabled.

I’m running Linux Ubuntu and can’t get Indigo to work.

I gave the light source a radius.


Enable Cache and Photons
Try enabling Buf.Shado for softer shadows.
Increasing ShadQu will also improve shadow quality; keep it below 0.95.
Increase the lighting energy or the GI Pwr.
Consider using HDR lighting

Increasing the quality will also increase the render time, but enabling Cache and Photons will help with this.

There is a lot of information in the documentation; it is well worth reading up on it.

Best of luck with it!