Weird lightning with smoothness

Hi.

I have this problem that happens a lot to me when modelling. I like to use the knife projection tool, it makes easier to make some things on a 3D model, however when I apply it, the face gets a strange lightning effect when it has smothness applied, see the image to understang better what I’m saying:

Just so you know, I’ve watched a few Youtube videos to get used to the interface and basic stuff and the rest I’ve learned was on my own using Blender so it might be a really dumb thing.

I already made sure the vertices of a face are on the same plane. The only way I find to fix this is by making that part with a lot more faces and leave flat shading, but I believe it will make render times a lot longer.

Sorry for my english and thank you for your time.

Bad topology, you need to mind edge flow while modeling and avoid Ngons (which you have a lot of)

Edit: Re uploaded .blend, the last one had some minor problems.

Attachments

[Blender] iPhone_00.blend (1.03 MB)

I tried to make another hole and made it that way (yes, it was suposed to have that shape)

(Damn, can’t I put the image smaller?)

About the edge flow, didn’t know about that, made some searches and learned what it is but can’t find any tool to do it. However I remember I saw some time ago a tool to make circles with few vertices ‘‘more circular’’ and I believe that it could be a good tool to work edge flow, I don’t remember what tool it was though, any ideas?

That’s much better but it does have some minor problems, you can turn on matcap in the ‘N’ tool panel under shading and choose from a variety of preview shaders to check if your mesh has any shading issues (make sure to check it from various angles)

Edge flow dictates the shape of an object, it’s mostly used with subdivided smooth.


The tool that makes circles you are talking about is the ‘to sphere’ shortcut (Shift-alt-s), it does not take into account curved surfaces as far as i know.

That’s a cool tool. Thank you for helping.

DCbloodhound is 100% correct that good topology is probably the best cure… Using the knife tool tends to create ngons and geometry that is unintended so you should always follow up the knife tool with the some clean up. (Also I like to use the J shortcut key to cut my mesh… Just select 2 vertices you want and edge between and the shortcut will cut a path to connect the two… Tends to be a bit cleaner.)

Also I might add that if you want to get really anal about the shading you should look into the vertex normals. Vertex normals are what control the way shadow is formed on the model…And mostly it’s handled automatically under the hood by blender. But there are a few modifiers and addons that allow you to tweak the buggers to great effect. There was a great article on the topic on polycount awhile ago on the subject. Pretty nifty. :wink:

Link to thread:

and just so I don’t leave you high and dry the 2 addons for manual vertex editing are Blend4web and Yet Another Vertex Normal Editor.