Weird Lines appaering in Textured Model

Here’s picture: https://ibb.co/Fx8Wnqx

Here’s the file if anyone wants to take a look at it: https://gofile.io/?c=7oVwzW

This Model only has a Mirror Modifier. I’ve used smoothing on this model a lot more than usual. And this model doesn’t have any double or excess vertices when using the basic detection settings. Thanks in advance.

This likely is related to background texture color coming through when zooming out and is called mipmapping. See related post. Tldr try to overpaint your UV islands with a border of the texture main color of approximately 2-4 pixels wide (it doesn’t mean you need to invent 2 px wide brush, the end result should look like that). Or shrink the UV islands.

On a side note, paste the files (screenshots and blends) directly into the post please so that they aren’t lost after sometime somewhere else and don’t require going through links to look at them.

First, add a little bleed to your textures to help with this, but on the texture node you can try changing the interplation from liner to smart

@Zak_Gre how do I over paint the UV islands exactly and how do I shrink them? Shrinking them sounds easier.

@joseph_raccoon I’ve tried increasing the bleed all the way to max and it hasn’t helped. And changing the node from linear to smart didn’t help either.

Thanks for your fast responses guys.

Overpainting can be done either by painting directly on the image texture in Image editor with a brush of the same color as the texture to manually create bleeding around UV islands or automatically with Bleed option.

Automatically this can be done in Texture paint mode, Options > Project Paint > Bleed (for 2.79). Increase it to 4 or 6 px. Then paint with those settings on the mesh, either with usual brush or with gradient paint (as your texture so far is one color).

Shrinking islands is done by scaling them. If there are multiple of them then try to use Individual origins as pivot point in UV editor, then scale (for very small amount). This might not work evenly if islands shapes are irregular. This method assumes texture is already drawn and won’t change; otherwise the method is practically useless as if baking or drawing with texture paint atop of shrunk islands the problem will appear again while UV islands will be smaller hence the texture resolution as well (a tiny bit but still).

1 Like

@Zak_Gre Thank you so much. Painting around the islands worked for me.

In the screenshot you’re using one color. Could make the whole image that color to start with, no painting around anything.

Another fix option that wasn’t mentioned, at a quick glance, is making the colored areas bigger. Could do that in an image editor, or in Blender compositor:


Color key makes black parts transparent, which inpaint can work with, and alpha over puts the background color back.

2 Likes