weird problem


(gargola) #1

hey guys! …well i don’t know how to explain this.you better take a look for yourself. http://mysite.iptic.com/gargola/MR.V.zip and please tell me what the hell happened there??? first,look at the character and the hammer and notice that everything is in position,the arms the shoes,the size of the hammer…etc. then press “p” to play and see what happens. :x :x


(OTO) #2

Well, this is the classic “no aply size/Rot” error i guess!!
Before parenting you must always do Ctrl-A to “Apply Size/Rot” to your
objects.
Try to unparent without tranformation apply and reparenting
Bye
António


(ineedanewbi) #3

yea… its kind of confusing and weird… scaling the object is different from scaling the verticies in the object… and rotating and so on

a bit of advice…
you should really learn how to use armatures for character animations and possibly lower the poly count in the eyes, lots of unnessessary verticies

unfortunately i dont really know where all the tuturials went after the original bender site went down… maybe someone else knows where the tuturials are… the huge collection of them.


(gargola) #4

i say it’s weird…cause i’ve made some projects without that problem.and it’s the first time someone tells me to do that…(i don’t even know what is that Ctrl-A do…it’s the first time i hear of that LOL :slight_smile: )anyway,thanx for your help guys! :smiley:


(gargola) #5

By the way OTTO…you got some great tutorials on your page!!! :smiley: i have learn a lot with them.it would be good if you make a “jumping” tutorial.the one i got is not good.when you try to make a character with armatures jump,it’s a real pain. 8) :smiley: :smiley:


(gargola) #6

hey guys…that ctrl A thing works very good…but the arms and the hammer doesn’t stay in place when i move the character.the arms are parented to the body and the hammer to the arm,when i press “p” to play and move the character(turning) the arms separate from the body.the hammer does the same when the character moves the arm.what’s wrong now? please help! :smiley:


(S_W) #7

I think I had a similar problem, too…but I can’t remember what I did wrong :frowning:


(gargola) #8

:frowning: well sometimes this gets very weird LOL.i don’t have that problem with the other games. :frowning:


(gargola) #9

i found a way to fix the prob. thanx S_W :smiley:


(OTO) #10

Hello Gargola

thank you for the kind words about my tuts!!

When you use separate meshs to make a character , it’s better to use
emptys to control things
Parent emptys to the main mesh and them parent the hammer to the empty

Bye
António


(gargola) #11

got it! thanx for the tip :wink: :smiley:


(Pooba) #12

is there any way to apply only size? Applying rot changes the axis fo the object.

Pooba