Weird simple problem, plane texture renders, but wont show in 3d viewport.

As per the title, I got a plane that i’ve textured and the texture is ON the object. but it wont show up in textured mode, it just becomes a white mesh. Why?

SimpleChar_3.blend (497 KB)

Option 1
Up unwrap the plane and select your sword image in the UV/Image editor
Option 2
Change textured display mode from Multitextured to GLSL. You would also need to apply the material and texture to your character as weel and add lights to your scene

Attachments

SimpleChar_3.blend (100 KB)

Sorry, but that didnt work, i tried option one, marked all seams and unwrapped and the sword texture was selected, but its still just a white plane.

I also cant do option two, i can change it to GLSL but the models texture dissapears, and when i make a new material for it, theres no texture in the texture list except the sword?

Scrap that, managed to sort it now, i must have borked up somewhere. Just redownloaded the upload here to save my 2 hours of texturing from being completely wasted!