Weird startup problem

I’m having a weird startup problem with Blender.

When I start Blender first it wil load my default scene then it wil automaticly open a blender file I opened earlier, after that blender pauses for a while and my blender default scene apears again.

This problem occurs with Blender 2.78, I uninstalled 2.78 and installed 2.79a the same thing happens.
I deleted al my preferences for current and older blender installations, no change.
I deleted al the Blender files in my Temp folder, no change.

I dont understand the problem, can anyone help?

I have no idea what the problem is but I can offer you a possible workaround.
Try to create a folder called config in /path-to-your-blender/2.79/ this will isolate blenders settings from anything that might be wrong with your system.


If You are sure You have deleted all Blender file…Even those stored in hidden folders…???

Then go Download realease or dailybuild Blender…Download the Zip file…!

Our friend who has given us Blender…Have said no need to install Blender…So Don’t Install it…Just unzip to where You wan’t it.

Run the Blender.exe…Make a shortcut maybe…:slight_smile:

On a Windows…You will find the Hidden folder in the AppData Folder/ Roaming…Puff Puff

If it still load Your file I will say…Hmmm…:slight_smile:

Check if You have Deleted All File.


I didn’t want to address Ton’s feelings about installations (although I have to agree with him).
Anyways even with a .zip distribution of Blender you should go the way I mentioned in my post. So you can be sure to have a unaffected selfcontained version of Blender.

I Think it’s a glitch in my graphics driver. I recently had a similar problem with Photoshop.

I used a version of Blenden from Graphical, it is a selfcontained zip. The problem still persist.

Die you try to create said config folder?
Seems wird to me, that a graphics driver should cause programs to temp load random files. But then I am no expert…

Not sure the graphics driver actually loads that scene. And it is also not random: If I understood the OP correctly, he always sees a brief glimpse of the last scene he had opened in Blender within the same OS session.

I think an issue with the graphics driver actually makes a lot of sense, e.g. a buffer update issue that shortly shows the last content of the frame buffer before it gets refreshed.

@IkariShinji: Ok. that really make sense. Didn’t think about the premisse of the same session.
Anyways, now it would be really interesting what system and driver we are talking about.

Only other thing I can think of is if it is saved as a startup file if it isn’t a graphics buffer issue. Does the header at the very top of the screen show a file path or is it just blank when the other session pops up after the default screen? Also when you tried a new install of Blender did you select import previous blender version settings and preferences? As that will essentially make the new install the same as your previous version.

The header did show the file path. I unzipped a new blender version from I didn’t do a full install. This is probably why the file association with my .blend files is broken now.

I deleted the config folder and restored it from backup, it didn’t help. I also cleared all the files not just the Blendfiles from my temp folder, no effect.

Since yesterday I’m not having the problem anymore, but I dont know what caused it or what solved it. My graphics driver is up to date, so I haven’t reinstalled it.

I havent done anything else to try and solve the problem, so i’m stumped.