Weird transparency results

I have an image that I am using in render that contains an alpha layer that I use to make part of the image transparent. It worked just as I wanted it too, but when I added some glass between the camera and the plane with the semi-transparent plane, the transparent portion isn’t transparent anymore.

No Glass:
http://www.blenderman.org/modules/coppermine/albums/userpics/10282/Building-NoGlass.jpg

Glass with IOR(1.00)
http://www.blenderman.org/modules/coppermine/albums/userpics/10282/Building-Glass.jpg

Does anyone know why this happens and if there is a way to fix it?

I have had similar problems with transparency which drove me to drink trying to figure them out. A couple things I would check…

First (of course) make sure Raytracing is turned on.
Make sure Raytransp is turned on.
Make sure Fresnel is turned up or alpha is turned down.
Make sure everything behind the glass has Traceabl and TraSha turned on.

I hope this helps.

Dbugged: I tried all of those things and no luck, thanks for the ideas though. For now, unless I hear some more ideas I guess I’ll just have to eliminate the glass.

You are rendering this in Yafray, correct?

It may be a bug that you can report at www.yafray.org

You may be best to try your luck in the forums there too. eeshlo or jandro will get you the correct answer to your problem.

Other than what has been mentioned to try, I have no clue.

BgDM

You´ve used RayTransp for the transparency?
Maybe then increasing the RayDepth value?
BTW, a very nice picture of Pennstation you´ve got there… :smiley:

Bye, Olaf.