Weird Z-Order in Game Engine

I’m kind of stumped as to what is actually wrong here…

The faces/normals seem to be rendered in some weird Z-order or something
I get the same issue in GLSL too, but looks normals look normal in Texture Face mode.

She is supposed to look like this (in editing mode)

The model renders fine when rendered, but the problem happens when the model is put through BGE. Is there anything that can be done short of rebuilding the model?:frowning:

  • Resolution -
    Apparently something funky was happening when I use Transparencies, not exactly sure why though. Thanks for the help people. :wink:

When dealing with alpha, it is best not to mix tris and quads. The problem is that this are stored separately and thus sorted separately. So you can either try to get rid of any tris (turning them into quads), triangulating the whole mesh (I suggest having a back up), or separate out the tris and quads into separate obejcts.

I’m not using alpha in my textures, and turning all quads into tris doesn’t help.

Then make sure the z-transp button is unchecked in the material panel.

I don’t think I’ve seen that problem before.
Can you upload the blend?

I think it’s sort of fixed, but what can I do if want to have some simple transparency?