Just to note the version available at github is broken but the gumroad one is ok, or at least it was for me. I too notice that it doesn’t give a continuous weld sometimes with planar objects but its pretty good. Example blend attached. Thanks for sharing :slight_smile:


weld missing in part.blend (460 KB)

Very nice thanks for the share :wink:

can you fix github repository?
I rename Welder to Welder.py, then i can turn it on in blender, but can’t execute it

Traceback (most recent call last):
File “/usr/share/blender/2.77/scripts/addons/Welder.py”, line 194, in execute
File “/usr/share/blender/2.77/scripts/modules/bpy/ops.py”, line 189, in call
ret = op_call(self.idname_py(), None, kw)
RuntimeError: Error: ‘/usr/share/blender/2.77/scripts/addons/weld.blend\Object’: not a library

location: <unknown location>:-1

Is this supposed to work in 2.78? It seems pretty useful but it doesn’t seem to work here.

You need to open the init.py and remove the line 220 to fix the issue. It should work normally.

^Yes, that fixed it, thanks!

Hi! Great addon!
Is it possible to make something similiar, but for … exterior (?) corners?

Maybe by adding weld to edges, selected in edit mode.

I have this erron on blender-git when i activate addon

Traceback (most recent call last):
  File "/usr/share/blender/2.78/scripts/modules/addon_utils.py", line 349, in enable
  File "/home/bm/.config/blender/2.78/scripts/addons/Welder/__init__.py", line 226, in register
  File "/usr/share/blender/2.78/scripts/modules/bpy/utils/__init__.py", line 619, in register_module
    raise Exception("register_module(%r): defines no classes" % module)
Exception: register_module('Welder'): defines no classes

& Error on 2.79a

Traceback (most recent call last):
File “C:\programi\b279a\2.79\scripts\modules\addon_utils.py”, line 350, in enable
File “C:\Users\py\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\Welder_init_.py”, line 225, in register
File “C:\programi\b279a\2.79\scripts\modules\bpy\utils_init_.py”, line 684, in register_module
raise Exception(“register_module(%r): defines no classes” % module)
Exception: register_module(‘Welder’): defines no classes

Zoinks, this is cool, if nothing else…just that I have no use for it…but I know a lot of people will use this to death…awesome idea.

Please download the recently updated version from gumroad. It should run fine on 2.79.

Yes, it is working fine on 2.79a RC.

Note to those who do it manually:

If Welder doesn’t show up on your add-on list but you have the script & the geo. in subfolder (ie. in “Welder”, as before) either:

- rename ‘Welder.py’ to ‘init.py’
B - put the script ‘Welder.py’ & the ‘weld.blend’ into the main folder ("…scripts/addons")

I taked some minutes and clean up script and made it easier to use/install. You no longer have to have separate blend with “plane” objects, etc - you can just pick welding object from the objects in scene. I also fixed count calculations to get proper results for weld objects of different sizes. If no weld object selected - script now just creates a curve along instersetcion

Thanks for helpful tool!

WOW! It’s Amazing!:stuck_out_tongue:

I get an oddity when I try to run it. I select both objects where I want the weld to occur, click the button for weld and instead of creating a curve, it creates an empty, drops into edit mode, but has no geometry. It stays in solid mode, I put the view into wireframe so you can see the result.


Added Note: If I try it on a cube with an intersecting sphere it’s fine. If I use a cylinder, even if they of different sizes, I get the above result.
EDIT: If I move one cylinder so it intersects the top of the other, then I get a curve. I’m uploading a short video to my YouTube channel to show what happens.

Video is: https://youtu.be/vxAHDDgZDcY

add loops to cylinder

… & if it doesn’t weld in full
(change count in Array modifier to fix)

Try boolean union, does it give any intersection vertex? Script make well job at combining vertex output into curve, but if no vertexes were emitted by boolean op - you will get nothing in curve. May be adding some subsurf before welding would help

It also does not account for non-uniform scale, so you have to Ctrl-A all objects before welding (including weld object itself)

Yep, that did it.

I was doing some tweaking to this and kinda merged it with early version of boolean bevel. I made some welds that were solid on the ends for “spot” welding.