What CUDA versions uses Cycles? 4.2 or 5.0?

Hi All.

I’m having a problem in general with CUDA in my system, and blender cycles work without a problem, so i would like to know if it’s related to the CUDA version Blender uses or if it’s related to other thing.

So my question is, what cuda version does cycles use? 4.2 or 5.0?

And where are the CUDA dll’s in Blender install?

Thanks!

Cheers.

This is probably not what you’re asking, but the formally correct answer would be 2.0 fully supported and 1.3 with limitations. But I guess you’re talking about the CUDA toolkit (which you don’t really need if you’re rendering under Windows and not doing development).

See also this one to check your GPU’s compatibility with Blender Cycles: http://www.systemagnostic.com/faqs/which-cuda-version-is-gpu/

If you’re asking for development purposes I’ll hand over to someone more knowledgeable on development than me.

I’m asking about that because I’m trying to hunt down a problem I have with CUDA in my system, and Luxrender with GPU and Blender Cycles with CUDA are the only renderers that are working, so NVIDIA devs are asking me about the CUDA SDK version Blender is using (4.2 or 5.0)

Thanks for answering!

Cheers

4.2 I’m pretty sure, but you might want to get a second opinion to verify.

Thanks Olesk! I was suspecting this :slight_smile:

Cheers!