What does this grass field lack?

Hello there, the following is a sort of pencil test of a project of mine which is in its modelling phase. I know it’s not that realistic but I’d like the grass field to look real. What is it lacking? The lighting and the backdrop are temporary. If the grass gets better, I’ll start to add some basic buildings to tryout the lighting rig of my project.
Here’s it:
Thanking you,

it is not a secret anymore :slight_smile: the answer is here

Thanks for replying. That’s the tutorial I followed to create this. I’m looking for a set up where the lighting is more or less overcast. Dull. I’ve stared my eyes out and can’t really come to a conclusion. So I was looking for a third-persons views.

I think it needs more colour and plant variation on the grass, it’s more like an even carpet right now.

Maybe that is it. To me the grass at the back somehow looks more real than the one in front. Perhaps it’s because of the brighter patches and thus more variety. But I can’t really do any updates till sunday. I don’t have access to the blend file at the moment. This took a long time to render. I had to render the ground divided into three. Each section at a time and later composited. And each section of the ground had the same particle assigned. You can see the line of division as a bluish line. Is there any way by which I can be rid of it? Or do I have to hide it with geometry?

Well, couldnt you just render a little more than you need for each layer, and then fade from one into another?

It’s so that, you need two or three different particle systems ontop of the main one, like in that tutorial, one for little flowers, the other for taller, different type of grass, all with probably a clouds texture to control colour variation etc… Also, why don’t you use “render border”? You can tell it which part of the full image to render, and you can put them together later in any image editor.

TobiasDN, are you saying that I should progressively reduce the length of the hair so that the start of the proceeding layers are hidden behind the preceding?

Pesho, are you talking about the button found at the bottom of the render panel? I didn’t really try that because I thought that no matter how small your border might be the entire particle field is calculated all at once. In which case it won’t help me as I have to add more grass than my computer can handle to get decent results. And how do you get to vary the color of the grass? I very much would like to know that.

You’re probably right about it caching all the particles no matter what part of the image is rendered… But you should still try, it might save you some rendertime regardless. Yes it’s that button, enable it, then to set a border, go to Camera view and press Shift+B. You can use textures to control all sorts of parameters for hair particles. Check this page:


It will tell you all you need to know about hair.

Not exactly (that way of doing it could work too though).
I think you could get rid of the problem by compositing a little differently.
Let different layers meet with a seamless fade, instead of just a rough edge.
Render a little more grass in each layer (so you have some room for the fade),
and the composite them together with soft edges.

Are you using z-combine now? I don’t think thats the best way to do it in this particular case. I think you should use blurred alpha’s as masks, and then use a mix node to composite them.

It’s kind of hard to explain. I do hope I made a bit more sense this time :wink:

To make the lighting look overcast, just use one or two big area lights.

it doesn’t have a windmill or a river or a broken wooden fence.

Hello there, Pesho, thanks for the link. I alway had overlooked it purposely. Found some useful stuff in it. Varying the color of the texture.

TobiasDN, I guess it’s a tough thing to explain! Are you saying that I should blur the alpha map and let the diff layers merge at the blur? If it’s not much of a bother could you post a simple illustration? I’ll be much obliged. The thing is, as I still don’t know how to use the render layers properly, I’m rendering each ground section separately with the alpha and composite it later in gimp.

tomrebel2, I was planning to use the deep shadow option found in 2.5. Get some self shadowing. But yours sounds reasonable. Will give it a fair try.

valek27, the final project will have a log cabin. Fine tunning it at the moment.