What does "Zombie Object!" error message mean?

Do I need to worry about it at all? I’m using endObject() to delete some objects on collision with the player so I assume it’s related to that somehow.

More details would be helpful- but as far as I can tell from a quick google search, it’s because references to the object caused it to not actually be deleted. I’m not entirely sure what this entails, but I’d assume it would mostly be a performance issue as the memory would not be freed up.

@Captain Oblivion is right. this should not happen in 2.49 (it could happen a lot in 2.48), so an example blend would be helpful.

i just got the same error

blend file is attached.

seems like the and controller for the ipo is not removed.
just press the up-arrow key and collide with the cube to test (takes a few milliseconds, because the cube has a health of 2 which removes it once it reaches 0.

the second problem i got is, that unused ipos and images are not removed, when i restart the blend file, but i think they were removed in earlier versions?
demonstration of that is inside the file too, because i cant remove the junk which remains because i stripped the original file for demonstration :stuck_out_tongue:

anyhow, thanks for the help

should i post this to the bug tracker?


zombieobject.blend (752 KB)

Apparently that comes from duplicated objects.

Attached to this message there is another example of zombie objects. Hey i liked this sentence, let me say again. Zombie objects. That’s cool, it’s awesome to debug zombies. Thank you.

Please notice: inside this example there is just to types of enemies: the standing one (white box one side red) and the moving one the orange box.

I inserted both of this “enemies” using the appending function. :wink:



Interesting blog post by Social, related post: http://theblendwithnoname.blogspot.com/2010/01/every-death-is-suicide.html


AMRELEASE1RevMatrixBZombies.blend (566 KB)

A note from my side, I bumped into this ‘Zombie error’ also. After looking into it a bit better, my object (being the duplicate of a linked object from another scene) was still parented to the object in the old scene (which was not active). Removing the parent-relation solved the problem for me.

Before ending the object, you should check if it is still valid, this can be done with:

if not object.invalid:

In 2.49b I had this problem because the parent of the Zombie Object was in a different layer. Logic bricks did not work while the object was a “zombie”. Moving the parent to the same layer fixed the problem.