What effects render times in Cycles

Ok, so I have a .blend file that I’m trying to render animation in. The file itself has millions of verts in it, but the background render layer that I’m currently trying to render only has influence from 360,000 verts. Even when I only had influence from 1037 verts in the scene, it was taking a ridiculously long time to render one frame (at 46 min and only a third of the frame rendered, I stopped it). So my question is this: does geometry and materials not being rendered, but in the file, effect the render time?

I’ve tried every trick I know of (which isn’t much) to reduce times. Non-progressive rendering, tiles at 32x32, max light bounces at 3, max transparent at 2(nothing transparent in the scene yet), only rendering the combined, depth, and AO passes. I can’t render GPU since my computer doesn’t have one, but I’ve never had this issue before in cycles. Please help me to understand how cycles looks at your .blend file and renders it.

I can upload the .blend if you guys need to see it.

Render times in a path tracer are going to be based mostly on lighting and materials. In theory you could have millions of unique polys in your scene and render times would only suffer a slight hit.

Yes, objects and materials not in frame must be loaded for global illumination calculations.

Indoor scenes and scenes lit primarily by indirect bounce lighting are always going to cause problems for unidirectional path tracing. There are a number of tricks you can use to speed this up, such as invisible area lamps in windows and hot spots, but in general indoor scenes are gonig to take longer to clean up. Scenes with many light sources are also difficult, as visibility has to be calculated for each light source at every hit for every object on every sample. Certain materials, like SSS, high roughness glossy, and high roughness refractive will also take more samples to clean up compared to sharp glossy or diffuse materials.

I have a course on Blender Cookieoutlining the most efficient way to diagnose where noise is coming from in your scene to optimize render times. It might be worth having a look if you’re having trouble understanding noise issues or path tracing in general.

Thanks Matt, I’ve watched your tutorial series a few times, and it was very helpful. I’m currently running on the most optimized non-progressive sampling from diagnosing from the different passes. I don’t have the “squared” option that you had, but I’m set to AA: 49, Diffuse: 25, Glossy: 20, transmission: 1, AO: 1, Mesh Light: 25, SSS: 1. Pretty low samples for the time it’s taking. I think my problem might be the amount of mesh lights. Also, thanks for the info on the rough glossy and rough refractive. I never knew that. I figured sharp glossy would take longer…

Would it be better to render an interior scene with the wall not seen removed? I don’t want global illumination to affect the final render, so do I set it to full black?

What version of Blender are you using? Around the time I added the square samples option there were some nice optimizations, so it may be worth it for you to upgrade. It’s been in for quite a bit at this point, so chances are your version is 2.67 or older.

You seem to be confusing environment lighting with global illumination. If you don’t want background lighting then yes you should set the environment to black, or power to 0. Global illumination is the light you get from light bouncing between objects in your scene. If you have diffuse bounces greater than 0 you are getting some amount of global illumination. What are your setting in the Light Path panel of the render settings?

I have 2.68a. Light paths are at 3 max 1 min, and diffuse, glossy and transmission all at 4.

I could have sworn my change made it into 2.68… hmm, either way, not so important.

What kind of scene is it? How many lights do you have? Are they mesh lights or lamps? If lamps, have you set the samples for those as well?

Also, with your max set to three, having the others set to 4 is doing nothing. If you’re doing an ourdoor/mostly directly lit scene try D-2, G-3, T-whatever you need to get through your transparent objects. Also try setting min and max to the same number. Having min at 1 can add a lot of noise to your scene, especially in transparent/glass/glossy areas. Also make sure caustics are off, and try setting the filter glossy to something high, I like to start with 10 and see if that helps. Are you using motion blur or depth of field anywhere? If not, 49 is pretty high for the AA setting. 16, 25, or 36 may give you a nice boost in render speeds if you then go through and do the noise reduction technique again. Chances are having such high AA is tossing samples at areas that are already cleared up while waiting for the others to do the same.

Well, I think upgrading to 2.69 did the trick. So far it’s much faster, and cleaner looking. Thanks for all the tips again, Matt. I always have my filter glossy at 0 because it sounded like it will blur the crap out of glossy areas, but I’ll look at it. I have your square samples and total samples script now, so that should help a lot. Rendering at 6 aa, 5d, 4g, 2t, 1ao, 5lights, and 1 sss. I do have DoF on, but turned off motion blur since it’s just a slow camera zoom for this scene. I have an interior hangar with a car parked in it. For lighting I have 6 rows of 6 mesh planes each. No lamps at all since I still can’t figure out the strengths of those (around 5000 to get them to look like an emission plane of 1). I’m going to open the wall behind the camera up and try not to lose any reflections in the car’s surface. The hangar had pretty simple materials too, with a few 700x700 tileables on it. I’ll let you know how it finishes, and leave a screenshot of the final render of one frame.

Just kidding. One frame clocks in at 2.5 hours… This doesn’t seem possible with my current computer… I think Mac OSX 10.9 has slowed down my computer considerably.

This is what took me almost 3 hours to render:


Should I delete all geometry in my “junk” layers? Is geometry that is not even part of the render affecting render times?

Hi, could you upload the .blend?
It is really hard to say without it but 2.5 hours seams way to long for such a render.
All geometry on the rendered layer affect rendertime, even it is not in camera view other layers not.
What are your system specs?

Cheers, mib.

Here is my .blend: http://www.pasteall.org/blend/25341

System I have is:

2.66 GHz Intel Core i5

16 GB 1067 MHz DDR3

ATI Radeon HD 4850 512 MB

OS X 10.9

I packed the .blend for you so you have the textures as well.

Hey sorry, been away for the day. I’ll download in a bit and try my hand at optimizing. Indeed, 2.5 hours seems excessive for that scene.

Thanks you two. I’m pretty sure if you guys can’t figure it out, no one can. :slight_smile:

I think I’m going to start building a render farm since my computer is getting old, and I’m not paying Apple for another expensive system.

Forgot to tell you guys. Set it to frame 180 because the lights are out at frame 1. Thanks again!

Can anyone figure this out? I’m worried that I will have to trash the model and start over, which will probably mean that I won’t start over. :stuck_out_tongue:

Sorry, been slammed and haven’t had a chance to give it a go yet. Tomorrow I’ll take a stab.

What needs to be changed in the file you provided to get the render you’ve shown? By default it seems that there’s something off about the compositing.

EDIT: Ah, my mistake, I see that the compositor points to the exr, not the actual render layers. Playing around with it now. Renders definitely aren’t close to 3 hours.

Thanks for the look, Matt. I didn’t pack the .exr because it was huge. Maybe my computer is just not good enough? Or did you further optimize the render settings to make it faster?

Still tweaking. Seems to be some other file I’m missing in the compositor, I get a pink result for the output, as if a texture is missing. My rig is faster than yours, but not enough to explain such a large discrepancy. I’ll get my tweaked settings posted here as soon as I’m done.