What Happend to the Alpha cannel in the Internal Blender Render

Use Blenders Internal render in blender 2.6 note its not the cycles render its just the normal one. I have my object and I render it and try to over lay it on top of a background and yet it is not showing the render as having a clear alpha channel. Try to put the alpha channel into the composite and view port and it shows it as all white. Is this a bug or is there now a new thing that must be selected? NoAlphachannel.blend (1.4 MB)

Changing alpha from sky to transparent in the render settings tab solves it.



that’s the setting (it somehow ignored this image in my previous post):


Wow you are quick thanks. It works now

you’re welcome!

Something is changed in the default alpha treatment in BI. It (almost) drove me mad a few weeks ago! :0
It wasn’t hard to figure out but before I could do that I began to question many of my assumptions.
It’s just that one is used to a particular feature so much that eventually one doesn’t really “see” it any more.