What happened to mist?

Since I haven’t fully made anything since 2.25, I’m kind of wondering…

What happened to basic mist, or fog? Usually it just sets a kind fog all around you, so that you can limit the distance away that you can see. The “mist” option in the world buttons doesn’t seem to have the same effect I remember though (if you have a moving object with your camera parented, things just seem to “disappear” into the mist).

Nobody? Come on, the old-timers have to at least know what I’m talking about.

There’s no more old-timers here, only “fresh” people who will make games for ps4!
Are you in a nostalgic mood?! :wink:
Myst was quite “weird” I guess, and still is?!
If you want “mist” as a “background limit” and no “fading” set “Start:” to a big value!
Bye

Hey, Myst is still my favorite game series, so you watch your mouth brother! :wink:

Regarding Mist, I wasn’t aware that it had changed. Admittedly, though, I never use it because it makes “Add” faces render incorrectly.

All i know about the mist is that they RUINED THE ENDING!! oh wait…blender mist. I think it is happening because in the newer versions of blender, for some reason, objects either too close or to far seem to just disappear ( no I am not a moron,the camera clipping is set to 0.1 and 5000, so that is not the problem,). I myself am an old timer of blender, i have been around since 2.20, and have been using 2.25 until 2.41!

Also PlantPerson, interesting fact: Supreme commander has the same “add in mist” problem blender does, even on high graphics settings. check it out if you play it. (hold space bar and look for distant firefights) :eyebrowlift:

If I have a simple object with a camera parented to it, and then make the object move forwards, everything disapears once the game runs for like 5 seconds. It seems like it’s just broken…

It just was an alternative to the abrupt end of clipping, where things just disappear. Instead, the edge of visible objects would be soft, kind of “gradienting” to the background.

Mist does work in Blender 2.46. You can activate it by going to the shading tab (F5) in the button window. Then go towards the bottom until you find a button called mist. Enable the mist button. You’ll also find mist setting below the mist button.

If I have a simple object with a camera parented to it, and then make the object move forwards, everything disapears once the game runs for like 5 seconds. It seems like it’s just broken…
Really? I never had too many problems with it (except for “Add” faces). Here is an example blend that uses mist. I hope this helps.
Also Sambassador, tell me if it works correctly on your computer.

  • Delta

Maybe it was just my work computer. Seems to be working alright on my home one…

Maybe it was just my work computer. Seems to be working alright on my home one…

simple object with a camera parented to it

Odd, maybe it’s some type of parenting bug?

Just the ending? The original is called “The Fog”. A mist is something that comes out of a spray bottle, not something enormous man eating creatures come out of. :evilgrin:

But as far as mist in the GE, it works just the same as it would in the render settings. It’s a little tricky to setup, but once you adjust the settings for a bit you’ll find it’s pretty useful. I was thinking about using it for my fade scene setup (with a moving camera to adjust the visibility), but went with a real fade scene instead.

Making funny of old (and tired) people is just too ugly!
Anyway, I never could pass the first “level” of Myst!

(this post should not be read as if it was said with a snotty attitude, it is meant to be polite, so nobody get mad) Actually BrianH, the mist is the movie adaptation of Steven kings short story “the mist”, which it fallows closely right untill the stupid ending.Yeah, that wasn’t a “mist” though, and in the book the edge of the fog is supposed to be extremely straight, which they changed for some reason.

anyway back on topic, The disappearing act happens when an object is parented to the camera, but us more than 50% off screen. The entire object disappears. I’ve had that problem when I tried an fps.