What happened to option of toggling receive shadows on and off

I have been working in Blender 2.8, and I cannot find the feature for a mesh not to receive shadows. In earlier versions of Blender, this feature was located under the material property -> shadow panel. However, it is not there anymore.

If this was due to the Blender developers removing it, then is there a workaround.

In Cycles, there is a ‘Shadow’ option under Object tab > Cycles Settings:
image
I don’t know if this is possible via Eevee.

As far as I know it’s not possible in Eevee. I really hope that will be possible soon, and even better: to have an option for lights to only affect specific Collections.

1 Like

Yeah, I see it, but doesn’t turning off shadows from object “A” also control all other objects not to receive shadows by object “A”? What if I want object “B” not to receive shadows from object “A”, but object’s “C”, “D”, and “E” needs to receive shadows from object “A”?

In 3ds max you can control if an object casts and/or receives a shadow, and you can exclude or include objects in lights. Blender has only limited options in this area.

Blender has only limited options in this area.

Blender having limited opitions is true. However, it is not the case with prior versions allowing you to toggle receive shadows on/off, as you can see in fig 1.

Fig. 1

image

These options where from the internal renderer that as been removed from blender and replaced with Eevee. As Eevee is still young it doesn’t have these options but chances are that they eventually get implemented.

1 Like

You can make the material using an Emission shader instead of P-BSDF… Now it does’nt receive shadows…

1 Like

This worked out fine for me